Closed Bug 418176 Opened 14 years ago Closed 13 years ago

Deleting more than one or two history items takes a long time

Categories

(Firefox :: Bookmarks & History, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 432706

People

(Reporter: joe, Unassigned)

Details

Note that this is *not* referring to the history sidebar (ie bug 402486). I was unable to test to see if that bug is fixed in my build, since it seems impossible to select more than one item in the history sidebar on OS X. I don't know if that bug has already been filed, though.

Anyways, using Beta 3 on OS X, selecting multiple items from the "Show All History" menu takes a long time - not hours or even minutes, but much longer than I expect. I can select, say, 20 items from my history, then hit delete, and have to wait for 4-6 seconds for Firefox to return control to me. This seems like something that should be a lot faster, i.e., instantaneous.
how much big is your history? are you using the default settings?
Yes, I'm using the default settings. My history looks to be about 17 000 items.
Forward duping because the newer bug has an owner.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 432706
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.