Status

Calendar
Provider: CalDAV
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Gustavo Solt, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648)
Build Identifier: Thunderbird 2.0.0.9 with last nightly version of the lightning

Hi!

The old versions have an XML request for caldav like:

<?xml version="1.0" encoding="UTF-8"?>
<calendar-query xmlns:D="DAV:" xmlns="urn:ietf:params:xml:ns:caldav">
  <D:prop>
    <D:getetag/>
    <calendar-data/>
  </D:prop>
  <filter>
    <comp-filter name="VCALENDAR">
      <comp-filter name="VEVENT">
        <time-range start="20080127T230000Z" end="20080303T230000Z"/>
      </comp-filter>
    </comp-filter>
  </filter>
</calendar-query>

I saw that the new one don´t have the time-rage,

<?xml version="1.0" encoding="UTF-8"?>
<calendar-query xmlns:D="DAV:" xmlns="urn:ietf:params:xml:ns:caldav">
  <D:prop>
    <D:getetag/>
    <calendar-data/>
  </D:prop>
  <filter>
    <comp-filter name="VCALENDAR">
      <comp-filter name="VEVENT">
      </comp-filter>
    </comp-filter>
  </filter>
</calendar-query>

So the response must be all the events from all the years, lol.

What happened with the time-range?

Kiss

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
This is by design. The CalDAV provider now has an associated memory calendar; refresh() updates the contents of the memory calendar with the contents of the remote CalDAV store, and getItems() (which is where the time-range comes in) is executed against the memory calendar instead of the remote CalDAV store. You don't see the time-range on the wire because it never needs to go there. Doing things this way results in a significant performance win as well as a more reasonable network-usage profile.

->INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.