Debug & QA UI menus are to the right of the Help menu

VERIFIED FIXED in seamonkey2.0a2

Status

SeaMonkey
UI Design
--
trivial
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: tonymec, Assigned: sgautherie)

Tracking

({polish})

Trunk
seamonkey2.0a2
polish
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008021801 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008021801 SeaMonkey/2.0a1pre

It is the custom across all applications that the Help menu be rightmost (last) on the menubar, the way File and Edit come first in that order. This is not the case anymore when Debug & QA UI is installed, because it puts its menus "after" the Help menu.

Reproducible: Always

Steps to Reproduce:
1. Load Suiterunner (Sm nightly) with DebugQA installed.

Actual Results:  
"Debug" and "QA" menus are "after" (right of, in LTR languages) the Help menu.

Expected Results:  
Help menu should be last.
Version: unspecified → Trunk

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
Status: UNCONFIRMED → NEW
Component: UI Design → Help
Ever confirmed: true
QA Contact: ui-design → help

Comment 1

9 years ago
I don't agree. I'm using dífferent versions of Seamonkey, and I prefer buttons to be in the same place. Maybe the additional menues could be separated by a large spacer?
(In reply to comment #1)
> I don't agree. I'm using dífferent versions of Seamonkey, and I prefer buttons
> to be in the same place. Maybe the additional menues could be separated by a
> large spacer?

Well, there used to be a fashion to have the Help menu at the far right of the menubar, and that would be "always in the same place" but I think that it's overdoing it and that moving all menus together was "the right move". However, the Help menu (and its menuitems, "Help Contents", "Check for Updates", "About SeaMonkey", etc.) is quite useful and IMHO deserves high visibility. It is more "visible" to me (and therefore more useful) when it is the last menu rather than being buried somewhere in the middle.

As for being "always in the same place", you cannot forbid extensions (not only yours but everyone's) from adding their own menus in the middle of the menubar: e.g. the Tabs Menu extension adds its "Tabs" menu (which includes one line for each currently open tab) between "Tools" and "Windows". What I propose is to place the "Debug" and "QA" menus between "Window" and "Help", which would make the Help menu IMHO highly findable, in fact more so than if it were always at the same pixel abscissa (or do you mean the same abscissa in millimetres? in percent of the screen width? in percent of the window width?)
Adding a couple CC to the people who seem to be in charge of Debug & QA.

Comment 4

9 years ago
Yes, this violates the HIG's (at least Apple's). We don't include the extension in releases, though (only test releases). One funny thing is that debugQAEditorOverlay.xul inserts the debug menu before the Help menu (open the Composer test page)
Component: Help → UI Design
QA Contact: help → ui-design

Comment 5

9 years ago
That's because that's where the menus always used to be historically. That's not to say that they shouldn't be moved, of course.
(Assignee)

Comment 6

9 years ago
Created attachment 345240 [details] [diff] [review]
(Av1) <debugQAMenuOverlay.xul>
[Checkin: Comment 7]

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2pre) Gecko/20081017 SeaMonkey/2.0a2pre] (nightly) (W2Ksp4)
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #345240 - Flags: superreview?(neil)
Attachment #345240 - Flags: review?(neil)
(Assignee)

Updated

9 years ago
Flags: in-testsuite-
Target Milestone: --- → seamonkey2.0a2

Updated

9 years ago
Attachment #345240 - Flags: superreview?(neil)
Attachment #345240 - Flags: superreview+
Attachment #345240 - Flags: review?(neil)
Attachment #345240 - Flags: review+
(Assignee)

Comment 7

9 years ago
Comment on attachment 345240 [details] [diff] [review]
(Av1) <debugQAMenuOverlay.xul>
[Checkin: Comment 7]

http://hg.mozilla.org/comm-central/rev/1efd609e5368
Attachment #345240 - Attachment description: (Av1) <debugQAMenuOverlay.xul> → (Av1) <debugQAMenuOverlay.xul> [Checkin: Comment 7]
(Assignee)

Updated

9 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: polish
Resolution: --- → FIXED
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081029 SeaMonkey/2.0a2pre - Build ID: 20081029180000

Verified for Linux on this tinderbox-build: the last three menus are now Debug, QA and Help in that order.
(Assignee)

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.