Ctrl + scroll wheel doesn't zoom

VERIFIED INVALID

Status

()

Firefox
General
VERIFIED INVALID
10 years ago
10 years ago

People

(Reporter: bugs-mozilla, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

I'm using the new Firefox 3 Beta 3 with an imported old_Profile (from Firefox 2.0.0.12). Ctrl + the scroll wheel of my mouse should zoom the page, but nothing happens. 

I tried it with a newly created profile and there everything works fine. I have disabled all addons in my old, imported profile and it still doesn't work. Using only the keyboard (Ctrl + "+"/"-") or the menu option the zoom works fine!

Reproducible: Didn't try

Steps to Reproduce:
1. Use Firefox 3 Beta 3 with an old profile (from Firefox 2.0.0.12).
2. Press Ctrl and use the scroll wheel in order to zoom the page.

Actual Results:  
Nothing happens.

Expected Results:  
The page zooms in or out.

I haven't had time to try it with another profile. Maybe I can generate a profile with Firefox 2.0.0.12 and import it into Firefox 3 Beta 3 later this week in order to reproduce this bug with another profile but I'm not sure whether I will have enough time...
(Reporter)

Updated

10 years ago
Flags: blocking-firefox3?

Comment 1

10 years ago
What's the value of the setting "mousewheel.withcontrolkey.action" in your old (pre-import) profile and in the imported profile? You can find this by entering the URL "about:config" in the location bar.
Version: unspecified → Trunk
(Reporter)

Comment 2

10 years ago
old (pre-import) profile:
mousewheel.withcontrolkey.action - 
status: user defined type: integer value: 0

imported (beta 3) profile:
mousewheel.withcontrolkey.action - 
status: user defined type: integer value: 0

new created profile:
mousewheel.withcontrolkey.action - 
status: standard type: integer value: 5

I reset the setting "mousewheel.withcontrolkey.action" in my old profile with Firefox 3 Beta 3 and now everything works as expected in Beta 3. What's strange is that the changed setting had no effect in Firefox 2.0.0.12 and now with Beta 3 the scroll wheel didn't work. But maybe that's just a weirdness with my profile and no bug in Firefox...?

Comment 3

10 years ago
Hmm... with this set to 0 it should not zoom in Firefox 2 either. As you can read in http://kb.mozillazine.org/About:config_entries#Mousewheel..2A setting it to 0 should simply scroll the document. Actually, there are more valid values for the pref than are listed there: 4 and 5 (the default in Firefox 3 beta 3) also exist.

Anyway, I think the problem is solved and this bug report can be closed?
(Reporter)

Comment 4

10 years ago
Yes, I guess it was just something messed up with my profile.

I'm setting this bug to invalid (can I just do this or does somebody else need to do it?), sorry for the unfounded bug report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 5

10 years ago
> can I just do this or does somebody else need to do it?

You can do that (as you probably noticed).
Status: RESOLVED → VERIFIED
Flags: blocking-firefox3?
You need to log in before you can comment on or make changes to this bug.