Recurring Weekly Event - First Entry Displayed Correctly on Tuesday, Recurrences Shown on Monday

RESOLVED INVALID

Status

RESOLVED INVALID
11 years ago
4 months ago

People

(Reporter: drankinatty, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-2.1 Firefox/2.0.0.12
Build Identifier: version 2.0.0.9 (20071114)

The lightning calendar recurring events correctly displays the time and date of the original event, however all following weekly occurrences are displayed a day early. (i.e. for a Tuesday recurring event, the first entry shows the event on Tuesday, all following recurring events show the event on Monday, a day early)

Screenshot:

 http://www.3111skyline.com/download/screenshot/tbird_lightning_recurrance_error.jpg

The calendar is retrieved via .ics from an eGroupWare 1.4.002 calendar over the internet. The rest of lightning appears to work fantastic!  Let me know what additional information I can send or any additional testing you want done and I will be happy to comply.

Thanks for the great work.

Reproducible: Always

Steps to Reproduce:
1. Set up weekly recurring event in eGroupWare
2. Set up new calendar in lightning to retrieve calendar from eGroupWare
3. Check the first occurrence of weekly recurring event and then check the following occurrences. They will all be one day early.
Actual Results:  
First event displayed on correct day, all remaining recurrences displayed a day early in the week.

Expected Results:  
Weekly recurrences should happen on the same week day.

See the screen shot provided above.
Could you attach a sample .ics file created with eGroupWare that shows the issue please?
(Reporter)

Comment 2

11 years ago
Created attachment 304108 [details]
.ics file requested

Stefan,

    Here is the .ics file. Thanks for your help.
BEGIN:VEVENT
CLASS:PUBLIC
SUMMARY:The Universe - History Chanel
DESCRIPTION:In depth documentories on space and physics
LOCATION:History Chanel
DTSTART:20080116T020000Z
DTEND:20080116T030000Z
ATTENDEE;CN=David Rankin;ROLE=CHAIR;PARTSTAT=ACCEPTED;CUTYPE=INDIVIDUAL;
 RSVP=FALSE:MAILTO:David Rankin<xxx>
RRULE:FREQ=WEEKLY;BYDAY=TU
PRIORITY:5
TRANSP:OPAQUE
CREATED:20080113T173144Z
LAST-MODIFIED:20080218T224046Z
UID:calendar-922-665131c5086929b43a72dff09ac360e1
DTSTAMP:20080218T231141Z
END:VEVENT

The event is specified to repeat every Tuesday at 02:00 UTC:
    RRULE:FREQ=WEEKLY;BYDAY=TU

But in contrast to this the first occurrence is not contained in the recurrence rule but is specified for Wednesday 16-Jan-2008 02:00 UTC:
    DTSTART:20080116T020000Z

For me the first event is shown on Wednesday 03:00 Central European Time (CET) because my local timezone is Europe/Berlin (UTC+1), all other occurrences are displayed on Tuesday 03:00 CET according to the recurrence rule.

If the timezone is set to e.g. America/New_York (UTC-5) this corresponds to Tuesday 21:00 Eastern Standard Time (EST) resp. Monday 21:00 EST.

See Bug 369043 for a similar discussion.
Component: Lightning Only → Calendar Views
QA Contact: lightning → views
Looks like we are doing the right thing w.r.t the spec, closing this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Flags: in-testsuite?
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.