Web services changes for Firefox 3 for Belarusian (be)

VERIFIED FIXED in Future

Status

Mozilla Localizations
be / Belarusian
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: Mic Berman, Assigned: Siarhei)

Tracking

unspecified
Future

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Tracking any changes to web services for Belarusian. Here's what I have as your defaults: 
Search plugins: Google, Yahoo, Amazon, Answers, CC, eBay, Wikipedia
There is a Belarusian version of Wikipedia - can you create a patch to add it instead of the English version?

Readers: Bloglines, My Yahoo, Google
LB: BBC

The new defaults for Mailto and calendar are expected to be
Mailto: GMail, YahooMail, Hotmail
Calendar: 30boxes, Google, Yahoo

The guidelines for making recommendations is here: http://wiki.mozilla.org/Firefox_web_services_guidelines

Thanks
(Reporter)

Updated

11 years ago
Blocks: 415572
(Assignee)

Comment 1

11 years ago
We already have Belarusian version of Wikipedia as search engine.

See bug 388035 for details.
Status: NEW → ASSIGNED
(Reporter)

Comment 2

11 years ago
my apologies. i believe we can close this bug then and I'll adjust dependency tree for tracking. Gavin can you double check for me based on bug mentioned above
thanks
(Assignee)

Comment 3

11 years ago
I think, we could close.

Now I don't have localized solutions for others stuff (Readers, LB, etc.).
I think, we could keep English ones.
(Reporter)

Comment 4

11 years ago
Siarhei
I'm having a hard time finding one but mustn't there be a decent Belarusian language news feed we can use?
if we could find one and add it that'd be great
also, often netvibes is available in many more languages. i did take a look and it seems there may be a Belarusian version, but can you double check..netvibes.com, look at settings, language, you can see if Belarusian is listed there
(In reply to comment #2)
> Gavin can you double check for me based on bug mentioned above

The current engines list for be is at http://lxr.mozilla.org/l10n/source/be/browser/searchplugins/list.txt . It doesn't match the one from comment 0, but I'm assuming that's OK because it has previously been discussed in bug 388035.

The existing engines look OK from a technical perspective. There are some minor style issues (OpenSearch vs. MozSearch and other little nitpicks), but nothing important enough to bother fixing.
(Assignee)

Comment 6

11 years ago
(In reply to comment #4)
They reports 99% for Belarusian translation.

But what should I do to add netvibes in Firefox?

Could you point me to a documentation describing such process?

I also ask our community about web services we could use.
(Reporter)

Comment 7

11 years ago
Netvibes is a common plug-in people are using. Currently the French, Ukrane and Polish teams are using Netvibes. If you ping any of them in the IRC L10n channel they should be able to help. Gavin may also know, I'll flag this bug to his attention.
Here is how to get to those teams: http://wiki.mozilla.org/L10n:Localization_Teams
Whiteboard: needs-patch, needs-gavin
(In reply to comment #6)
> But what should I do to add netvibes in Firefox?

You need to make a change to your region.properties file, so that it includes netvibes. Here's an example from the fr locale:

http://bonsai-l10n.mozilla.org/cvsblame.cgi?file=l10n/fr/browser/chrome/browser-region/region.properties&rev=1.20&mark=9,10

See also http://wiki.mozilla.org/Firefox3/L10n_Requirements#RSS_Feed_Handlers .
Whiteboard: needs-patch, needs-gavin → needs-patch
(Assignee)

Comment 9

11 years ago
(In reply to comment #8)

Thanks
(Assignee)

Comment 10

11 years ago
(In reply to comment #7)
> Netvibes is a common plug-in people are using.

I prepared replacement of Bloglines with Netvibes.

Do I need a special approval to commit the changes?

Can you attach the patch here, and I will review?
(Reporter)

Comment 12

11 years ago
from comment #10
no specific approval required from Netvibes. I have had discussions with them about adding as wanted
(Assignee)

Comment 13

11 years ago
Created attachment 305564 [details] [diff] [review]
region.properties patch

Done.
Attachment #305564 - Flags: review?(gavin.sharp)
Attachment #305564 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 14

11 years ago
I want to replace BBC with Belradio (http://www.belradio.fm/) in LB.


I think we need to ask approval from them. It is possible to contact them at

http://www.belradio.fm/en/404/contact/
Whiteboard: needs-patch → needs-mic
(Reporter)

Comment 15

11 years ago
Siarhei - can you be explicit in this bug about the rationale for making the change? For example, is it because Belradio is available in Belarusian and is a popular service for Belarusian speakers?
thanks
(Assignee)

Comment 16

11 years ago
(In reply to comment #15)

1) Belradio is available in Belarusian
2) The RSS content is changed quickly and shows latest news from Belarus
3) They have audio content

The resource does not have the best popularity in Belarus.

The most popular resource in Belarus is www.tut.by. But it is mostly in Russian. Also they doesn't keep RSS feed synchronized with the site content. 
For example, http://news.tut.by/rss/index.rss (all days news) shows one news from 03/01/2008, one news from 02/29/2008, three news from 02/28/2008 and so on.

There is another alternative Belarusian resource I could propose to use as default for LB. It is http://www.nn.by/. The content is Belarusian. RSS feed is synchronized with the site content. It is more popular than Belradio.
(Reporter)

Comment 17

11 years ago
Siarhei, given what you describe about www.nn.by and our guidelines: http://wiki.mozilla.org/Firefox_web_services_guidelines
it seems like nn.by might be a better LB because they are synchronized and more popular. What do you think? 
(Assignee)

Comment 18

10 years ago
(In reply to comment #17)

Ok. Let it be nn.by. 

Should I ask permission from nn.by myself or you prefer to ask them yourself?
(Reporter)

Comment 19

10 years ago
Siarhei - you can ask them directly if you wish. We simply need permission from them to include their service in the upcoming Belurusian Fx3 release, and so they expect whatever additional traffic we sent. Please copy me on the email you get in return and include it in this bug. Thanks
(Assignee)

Comment 20

10 years ago
(In reply to comment #19)

received permission for NN.BY from Andrej Dynko, NN.BY editor.

The copy of the mail sent to Mic Berman.
(Reporter)

Comment 21

10 years ago
have not received email yet (or can't find it for some reason), so as not to slow things down, Siarhei, you can copy and past email into this bug that'd be great :)
(Assignee)

Comment 22

10 years ago
(In reply to comment #21)

The email:
-----------------
Dear all,
 
we agree on using NN.BY RSS as an example for the Belarusian translation of Firefox.
 
Yours,
 
Andrej Dynko,
NN.BY editor
-----------------
(Assignee)

Comment 23

10 years ago
What should I do further to set NN.BY for live bookmark?

I see there is not direct reference for default live bookmark (BBC). There is link to http://be.fxfeeds.mozilla.com/be/firefox/headlines.xml .

I don't know how I could change the link target context.
(Reporter)

Comment 24

10 years ago
Siarhei - it now needs server side change. Over to Axel or Gavin. Thanks for providing permission.
Whiteboard: needs-mic → needs-pike
Should http://nn.by/rss.php be the feed url?
(Assignee)

Comment 26

10 years ago
(In reply to comment #25)
> Should http://nn.by/rss.php be the feed url?
> 

Yes. http://nn.by/rss.php is the feed url.
Filed bug 422653 for the redirect.
Whiteboard: needs-pike
The feed is up, I think we're done here. Cross-checking with Mic?
Whiteboard: needs-mic
(Reporter)

Comment 29

10 years ago
we're almost done, confirming (no need to verify)
final list of search is:
Google
Yahoo
be.wikipedia.org
be-x-old.wikipedia.org
ru.wikipedia.org-be
tut.by
yandex.ru-be

rss feed is: nn.by
rss readers are: google, yahoo, netvibes

Question: Siarhei can you confirm for mailto and calendar protocols Belarusian is ok with these en-US defaults: mailto= google, yahoo and hotmail and calendar=google, yahoo, 30boxes
(Reporter)

Comment 30

10 years ago
once that is confirmed, we are done ;)
(Assignee)

Comment 31

10 years ago
(In reply to comment #29)

I confirm the list.

It is all right with using en-US defaults for mailto and calendar protocols.
(Reporter)

Updated

10 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: needs-mic
You need to log in before you can comment on or make changes to this bug.