If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

no CSS2 width/height attribute apply when DOCTYPE XHTML 1.0 Strict declared

RESOLVED DUPLICATE of bug 193657

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 193657
10 years ago
10 years ago

People

(Reporter: Faalagorn, Unassigned)

Tracking

({css2, xhtml})

Trunk
x86
Windows XP
css2, xhtml
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008021804 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008021804 Minefield/3.0b4pre

When declared <!DOCTYPE> XHTML 1.0 Strict in HTML document, Firefox did not parse width/height declared in table by CSS2 locally (ex. style="{width:100%}"). Example below:

<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="pl" lang="pl">
 <head>
  <title>title</title>
 </head>
 <body>
  <table style="{width:100%;height:100%}">
   <tr>
    <td>main</td>
    <td style="{width:100px}">menu</td>
   </tr>
  </table>
 </body>
</html>

Such page is valid XHTML 1.0 Strict. When added a letter just after word PUBLIC (ex. PUBLICa), bug doesn't appear.

Reproducible: Always

Steps to Reproduce:
1. Open a file with DOCTYPE XHTML 1.0 Strict declared and table with CSS2 width and/or height attribute.
2. See the bug causing table not displaying properly.
Actual Results:  
Table was not displaying properly sized.

Expected Results:  
Set table width/height properly, how it was declared.
Your css looks invalid you should not have the surrounding {} I think
(Reporter)

Updated

10 years ago
Keywords: css2, xhtml
Version: unspecified → Trunk
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Your css looks invalid you should not have the surrounding {} I think
> 

Dunno, but W3C Validator (http://validator.w3.org/) showed no errors...

Comment 3

10 years ago
"height:100%" also might not do what you expect in standards mode.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 193657
You need to log in before you can comment on or make changes to this bug.