Bug 418311 (coalesce-day)

mac coalesced updates causing slowdown

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: vlad, Assigned: vlad)

Tracking

Trunk
x86
macOS
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Posted patch add plist keySplinter Review
We'll fix this properly once we do Compositor, but for 1.9, we need to just disable Coalesced Updates; we paint way too often, and with it enabled, we end up blocking quite a lot on graphics updates.

(ref: http://developer.apple.com/technotes/tn2005/tn2133.html)
Flags: blocking1.9+
Attachment #304107 - Flags: review?(roc)
Assignee: nobody → vladimir
Checked in.  Let's see what happens!
For future reference:

http://developer.apple.com/documentation/Cocoa/Reference/ApplicationKit/Miscellaneous/AppKit_Functions/Reference/reference.html#//apple_ref/c/func/NSDisableScreenUpdates

may be helpful; we can programatically disable and reenable screen updates.  We'll want this for when Compositor is involved.
Resolving OMGWTFFIXEDSOHARD.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Please file follow-on to have this US and Canadian holiday renamed to Coalesce Memorial Day.

Comment 5

11 years ago
Want this on branch as well?
Flags: blocking1.8.1.13?
Blocks: 418338
Alias: coalesce-day
Duplicate of this bug: 394943
We'll take a branch approval on the patch, but it isn't "blocking" a branch release.
Flags: blocking1.8.1.13? → wanted1.8.1.x+
Not necessary on the branch (and in fact may cause problems there) -- the branch is a QuickDraw app, and so the OS automatically disables coalesced updates for it.
Flags: wanted1.8.1.x+
You need to log in before you can comment on or make changes to this bug.