Components is not defined in calendar-invitations-manager.js

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: martinschroeder, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
I can't provide STR for the error message:
Error: Components is not defined
Source File: chrome://calendar/content/calendar-invitations-manager.js
Line: 472

Relevant code in calendar-invitations-manager.js:
getStartDate: function IM_getStartDate() {
    var date = Components.classes["@mozilla.org/calendar/datetime;1"]
                         .createInstance(Components.interfaces.calIDateTime);

I found a similar problem caused by not properly unregistering an observer:
https://www.mozdev.org/bugs/show_bug.cgi?id=12304

So, maybe there is a problem registering/unregistering an observer while loading/unloading calendar-invitations-dialog.js.
This is usually a result of the window context being gone when the function is called. Maybe the invitations manager does an operation with a callback that is called after the window has closed?
(Reporter)

Comment 2

10 years ago
Haven't seen this error in a while. Resolving as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.