Unable to pause streaming media in BBC iPlayer

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Andy Strong, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506; .NET CLR 1.1.4322; InfoPath.2)
Build Identifier: Firefox/3.0b3

when using bbc iplayer to listen to radio1 saved shows (listen again) i am unable to use the pause button in FF3 beta. the buton clicks but no action occours

Reproducible: Always

Steps to Reproduce:
1.go to www.bbc.co.uk/radio1
2.click on dj's shows
3.click listen again on Annie Mac's 
4.once the application is loaded an playing click on the paus button
Actual Results:  
button does not work

Expected Results:  
music is paused

Comment 1

10 years ago
Works fine for me, you tried playing in Safe Mode?
(Reporter)

Comment 2

10 years ago
Tired in safe mode also. no joy. button clicks but and goes grey but does not function.

what OS are you running on?



Comment 3

10 years ago
XP x64, Firefox 3 Beta 3

Fancy attaching a screen shot so we can clearly see where it's going wrong?
(Reporter)

Comment 4

10 years ago
Created attachment 304227 [details]
when button is clicked
(Reporter)

Comment 5

10 years ago
Created attachment 304228 [details]
normal operation
(Reporter)

Comment 6

10 years ago
files uploaded 
as reported on the bug i am running vista, it is (32bit) ultimate, fully patched, hence maybe a vista/FF issue

when you look at the attachments the only difference is the slight graying of the button when clicked. If you click on it again it turns white again. but no effect on the music.

if there is anything else i can do let me know


Comment 7

10 years ago
Well it seems to be working perfectly for me, when I pause it I don't get a greyed out button but just a play button.

Also I have a timer showing how much I've listened to of the total recording.
(Reporter)

Comment 8

10 years ago
And i also get exactly this functionality on IE7 and FF2.

unfortunately your testing on XP 64 does not replicate my environment.

 I will try a replication on my laptop which is running vista enterprise to see if it is machine based or vista/FF issue

Comment 9

10 years ago
I had similar problems with Fx2 before Fx2 final came out.  The BBC radio player worked in Fx1.5 but not in Fx2 nightlies.  It turned out that in order for the RealPlayer plugin to be scriptable, it is not enough to have the np*.dll files in the plugin folder, but some .xpi files are also needed (I don't remember their exact locations).

Have you tried reinstalling RealPlayer?
(Reporter)

Comment 10

10 years ago
Running real V10 on desktop with issues

installed v11 on laptop for testing and it works ok 

will upgrade real player on desktop to latest version and confirm success



(Reporter)

Comment 11

10 years ago
Upgraded to V11 real player can now pause tunes when people annoy me 

thanks for all the help

Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
changing to worksforme, because Fixed mean in bugzilla that a CodeChange (patch/fix) in Firefox resolved the problem.
Resolution: FIXED → WORKSFORME

Comment 13

10 years ago
Don't understand why this is 'Fixed' unless you are suggesting users will have to re-install RealPlayer after Firefox 3?

Comment 14

10 years ago
Erm, my understanding is not so much that they need to re-install, but just update to the newest version. I don't think it's too much to ask that plug-ins be uptodate if they expect them to work on new plugin content.

Comment 15

10 years ago
(In reply to comment #14)
> Erm, my understanding is not so much that they need to re-install, but just
> update to the newest version. I don't think it's too much to ask that plug-ins
> be uptodate if they expect them to work on new plugin content.

I updated RealPlayer from V10 to V11 and that fixed the iPlayer in FF3Beta5,
HOWEVER I have just tried on another PC (also WinXP SP2). I updated RelayPlayer first to V11 and then installed FF3 Beta5. The BBC iPlayer controls then don't work, and I can't update RealPlayer, so I'd have to re-install :)


You need to log in before you can comment on or make changes to this bug.