Bookmarkable template triggers double file logic

RESOLVED WORKSFORME

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Kevin Roberts, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: 3.0.3

Whenever I use one of my "bookmarkable templates" to create a bug I get the warning:

You have already used the form to file bug xxxx.

And I have to click on the "File bug again" button to actually file the bug.

We use a couple bookmarkable templates extensively.

Reproducible: Always

Steps to Reproduce:
1. Create a new bug and click on the "Remember values as bookmarkable template" button. 
2. Use the bookmarkable template to create a bug
3. Try creating a second bug.
Actual Results:  
Warning message appears

Expected Results:  
The software should not trigger the double-entry logic if the bug is being created with a "bookmarkable template". Stopping to reconfirm every time negates the value of the bookmarkable template feature.

It would be good to be able to turn off the double-entry warning feature.
This seems to be bug 372723, which has been fixed for 3.0... Do you have a line

   $vars->{'url'} = $cgi->canonicalise_query('token');

in your post_bug.cgi?

Comment 2

11 years ago
WFM using the not yet released 3.0.4. The reason you still get this error is because the token feature has been implemented in 2.23.2 in bug 42946 before it has been fixed in 3.0 (before its release!) in bug 372723. This means you either installed 2.23.2, 2.23.3 or 2.23.4 and you added these links to your bookmarks during this timeframe.

The fix is to load enter_bug.cgi using your bookmarks and then click the "Remember values as bookmarkable template" button again to generate a correct link for your bookmarks, which will replace your broken one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

11 years ago
You are correct re originally having created the bookmarkable templates with an earlier version of Bugzilla, but I have recreated them and still get the warning.

I followed the recommended steps in comment #2 and I still get the warning message.

Once I use the bookmarkable template to create a bug, the next time I use the same template to create a bug I get the warning again. If I exit my browser and restart it, the template will not give the warning the first time I use it, but it does the second time I use it (if I haven't restarted my browser session).

Comment 4

11 years ago
Weird, I cannot reproduce (I created 4 or 5 bugs consecutively, without any warning). Does your bookmarked link still contain &token=xxxxxxxx in it?
(Reporter)

Comment 5

11 years ago
Nope. The link contains all the field values, but no token.

Comment 6

11 years ago
So this error cannot happen as post_bug.cgi won't complain that the token is invalid (which is the check it does internally).
You need to log in before you can comment on or make changes to this bug.