Change default text for untitled events from 'Untitled' to 'Busy'

RESOLVED WONTFIX

Status

Calendar
Calendar Views
--
enhancement
RESOLVED WONTFIX
10 years ago
9 years ago

People

(Reporter: erskin, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Lightning 0.7, Thunderbird version 2.0.0.6 (20070728)

When an event has no title, it shows up in the various views as 'Untitled'.
The default title for new events created is 'New Event'.

I am proposing that events which have no title (a null string) be rendered as 'Busy' instead of 'Untitled', as it is a more accurate representation of what is known about an untitled event, i.e. that the time has been reserved for some purpose.

While new events are created with a default title of 'New Event' (for which 'Busy' may be a better choice, but that's another issue), other calendar tools (i.e. Google Calendar) create default events with no title and display such events as if they had the title 'Busy'.

I recognize that this issue lies dangerously within the realm of personal preference, but propose it anyway, as I feel that 'Busy' makes for a better default for the "average" user than 'Untitled'.

(This is to say, that while I am suggesting this, I won't lose any sleep if it is promptly rejected.)

Thanks again for making such an excellent product!


Reproducible: Always

Steps to Reproduce:
1. Create a new event.
2. Clear the 'New Event' text from the title.
3. Save it without a title.
4. View the event (not the details) in any view.
Actual Results:  
Events are displayed as 'Untitled'

Expected Results:  
I am proposing that the events should be displayed as 'Busy' instead.

Comment 1

10 years ago
IMO it's a WONTFIX/INVALID.It can be displayed as 'Busy' only if 'Show time as busy' is selected.

Comment 2

10 years ago
And this is bug 415376

Comment 3

10 years ago
Created attachment 304452 [details] [diff] [review]
Change 'Untitled' and 'New event' to 'Busy'

(In reply to comment #0)
> I am proposing that events which have no title (a null string) be rendered as
> 'Busy' instead of 'Untitled', as it is a more accurate representation of what
> is known about an untitled event, i.e. that the time has been reserved for some
> purpose.
> 
> While new events are created with a default title of 'New Event' (for which
> 'Busy' may be a better choice, but that's another issue), other calendar tools
> (i.e. Google Calendar) create default events with no title and display such
> events as if they had the title 'Busy'.

Both could be achieved easily, but does it make sense for everyone?

I could imagine to add these strings to the prefs, but then it would be client specific. IMHO this all is only relevant for shared calendars, because I wouldn't care about the display of events for which I did not set a title...

So I would see 2 solutions:
- do the attached modification on your own
- always enter a title, maybe 'Busy' in new events (to save some time, you may want to continue watching bug 417783)

Comment 4

9 years ago
As this could be fixed by fixing bug 417783, resolving this as WONTFIX, as it's not real dup.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.