If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Almost every time I try to open Microsoft Word while Firefox is running, Firefox locks up, "Not Responding". I have to CTRL Alt DEL to the Windows task manager and do an End Process on Firefox.exe

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: Arnie Polikoff, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

Almost every time I try to open Microsoft Word while Firefox is running, Firefox locks up, "Not Responding". I have to CTRL Alt DEL to the Windows task manager and do an End Process on Firefox.exe. After Firefox closes I can open Firefox again and restore the session and it works fine.

Reproducible: Sometimes

Steps to Reproduce:
1. Open firefox.exe
2. Open any web site
3. Open Microsoft Word 2000 (9.0.3821 SR-1)

Actual Results:  
Firefox says "Not Responding" and uses 100 % of CPU

Expected Results:  
Firefox should not lock up my computer.

Instead of going into a "Not Responding" state and using 100% of the CPU, Firefox should just shut down.
This is an old machine, right?  How much memory?
Do you see this problem with firefox 3 with a clean (new) profile?
Whiteboard: closeme 2008-11-17
(Reporter)

Comment 2

9 years ago
It should not matter how old my computer is. I have enough memory. This is a problem that many people complain about. If you Google "Mozilla Firefox Not Responding" you will see many people with the same problem. The problem still exists with the latest version of Firefox. It also happens with my brand new Dell laptop running Vista. The problem is with Firefox and is computer independent and platform independent. 

Even with its flaws, Firefox is still much better than IE.
Some helpful information you can provide us is found at http://quality.mozilla.org/bug-writing-guidelines. You should also use a recent version of Firefox, from http://www.getfirefox.com. Please answer the questions in comment 1, they are important to fix this issue. bmo is not a support forum. Firefox 2 is not supported anymore either.
Whiteboard: closeme 2008-11-17
Version: unspecified → 2.0 Branch
(Reporter)

Comment 4

9 years ago
I am using Firefox version 3.0.5. My system is windows xp professional version 2002 SP2 AMD Athlon Processor 756 MHz, 256 MB RAM.

How can I see how much memory my machine has?

What do you mean by, "Do you see this problem with firefox 3 with a clean (new) profile." What is a clean profile? How do I make a clean profile?
Version: 2.0 Branch → 3.0 Branch
http://quality.mozilla.org/bug-writing-guidelines has info on new profiles and other diagnostic stuff. You just gave us your mem, 256MB.
(Reporter)

Comment 6

9 years ago
I am closing this bug report because the problem has not occurred for the past few weeks. I also am not that computer literate to be able to find out how much memory my computers have or to create a new profile. I am using my Dell laptop that I just bought last month running Vista right now. I have not had the bug problem on this computer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Arnie, thanks for following up.  I had just written the following which may be helpful...

This isn't firefox's fault unless you are hitting specific pages that require high memory due to specific problems - which I'll bet is unlikely in your case.  You need 512 for XP, fixable for ~$30 of memory.  Yes, firefox's system specifications state 256meg - but in practice that's bogus and I wish they'd change those figures. It might do for w2k, but I ran windows 2000 with 512 which was just adequate - and XP requires more than w2k.  I can't imagine running XP with 256mb.

(In reply to comment #0)
> Actual Results:  
> Firefox says "Not Responding" and uses 100 % of CPU

windows is saying this, not firefox
 
> Expected Results:  
> Firefox should not lock up my computer.

windows again
 
> Instead of going into a "Not Responding" state and using 100% of the CPU,
> Firefox should just shut down.

firefox won't shut itself down based on the OS's performance

so your initial report is => invalid for the XP-based issue.

lastly, if the problem went away on its own with no change in firefox then this should probably interpreted as being an issue with your pc/network environment and closed invalid rather than worksforme.  I'll leave it to you as to whether resolution should be changed.


(In reply to comment #2)
> It should not matter how old my computer is. I have enough memory. This is a
> problem that many people complain about. If you Google "Mozilla Firefox Not
> Responding" you will see many people with the same problem. The problem still
> exists with the latest version of Firefox. It also happens with my brand new
> Dell laptop running Vista. 

I just tested my Dell latitude laptop, vista with ~300meg (I normally run it with ~850meg) and word 2003 and it's barely usable using basic html pages.  pages with large images and flash would intolerable.  I wouldn't run vista with any application on less than 1gig.  And on a laptop the likelihood of getting "not responding" is greater because laptops normally have slower disk drives.

the google hits I see based on your search parameters are in fact few, plus not all people's reports are accurate. Clear details with reproducible examples are required. For example, you tell us nothing about your vista laptop, no URLs nor cite verified reports from the examples you find via google.  If you have at least 1gb memory on vista and have a performance problem I suggest you really want to support http://support.mozilla.com/en-US/kb/Firefox+Support+Home+Page
(Reporter)

Updated

9 years ago
Resolution: WORKSFORME → INVALID
You need to log in before you can comment on or make changes to this bug.