After downloading a file in FF3 beta x.x Release, the file has Read-only permissions. This problem does not occur when I use Safari 3, however.

RESOLVED DUPLICATE of bug 401316

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 401316
10 years ago
8 years ago

People

(Reporter: Alec, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3

Downloaded MS office files are being put in Read-Only format after being downloaded. 
This does not happen if I use Safari or another web browser...

Reproducible: Always

Steps to Reproduce:
1. Download a file from our Sharepoint Server
2. Check file permissions, change from RO to R&W permissions
3. Done
Actual Results:  
After I change the permissions, everything is fine, but it happens EVERY time.

Expected Results:  
It should download the file without appending any file access permission changes.

Comment 1

9 years ago
I can confirm this bug/problem. It seems to have been introduced by https://bugzilla.mozilla.org/show_bug.cgi?id=280419

Although this behaviour may be useful, and might even be a good default, there really needs to be an option to turn this off. There are lots of buggy applications out there that don't work well when the file is read only.

I looked at the code in uriloader/exthandler/nsExternalHelperAppService.cpp and discovered that the code skips changing the file to read only if browser.helperApps.deleteTempFileOnExit is set to false. So as a workaround you can set that in about:config. This has the side effect of leaving lots of files lying around though so it would be nice to have browser.helperApps.readOnlyTempFiles or equivalent.

Comment 2

9 years ago
Same problem here !
I work with firefox 3 and open office 2.2. and windows XP
Everything was fine till FF version 2.0
The solution browser.helperApps.deleteTempFileOnExit could be very dangerous as i generate trough a web application an .swf file. Keeping all the old files generated could cause other problems .

thanks in advance

Comment 3

9 years ago
Same problem here when I download a self-installing .exe from a trusted software supplier (this happens with more than one supplier, but www.jam-software.de is typical):   the download to the temp directory works OK but the message comes up that the file cannot be run.   Examination shows the .exe to be read-only and when that's removed the .exe can be run and thus the software be installed.     XP SP3   FF 3.0.08

Comment 4

8 years ago
This was fixed on Mac in bug 401316.  Windows users should see bug 439938.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401316
You need to log in before you can comment on or make changes to this bug.