Filter UI: Case where new filter isn't added to list (ever)

VERIFIED FIXED

Status

P3
major
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: laurel, Assigned: alecf)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] fix in hand)

(Reporter)

Description

19 years ago
Using:
2000-06-07-08 m17 commercial build, NT 4.0 and mac OS 9.0
2000-06-07-10 m17 commercial build linux rh6.0

A newly added filter is not retained when following the steps below.  The filter
is not added to the filter list, does not appear after OK from main dialog and
reopening dialog, doesn't appear in list even after exit and restart.

1.  From mail window, launch message filters ui (Edit|Message Filters). In the
main dialog, click New to launch filter rules dialog.
2.  In the new filter rules dialog, type a filter name, select AND/OR, fill in a
simple subject contains <text> criteria line.
3.  In the Action section, leave the action set to Move To Folder and leave its
corresponding value dropdown (where you'd normally select a destination folder)
blank.  Click OK to confirm out of the filter rules dialog.
4.  An alert displays telling you to select a destination folder. OK the alert
and then select a destination folder (on the same server). OK from the filter
rules dialog.
5.  Notice the new filter doesn't appear in the main dialog's filter listing.
Click OK from the main dialog and go back in. Filter still doesn't appear in the
list. Close the dialog (by OK, Cancel or close box).
6.  Exit Netscape, relaunch and go to message filters.  Filter doesn't appear.

Result:  Filter is not saved, even after exit/relaunch. Not displayed in ui, not
saved in rules.dat.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → laurel
(Assignee)

Comment 1

19 years ago
fixed. problem was just broken logic when we popped up an alert.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

19 years ago
Using jun08 commercial build this is not fully fixed, but has changed.
The filter does indeed wind up displayed in the main dialog's filter list, but
the filter gets saved without any of the criteria.  If you edit the filter,
you'll see the filter rules dialog has no criteria lines (even a default blank
one!) and the filter is written to the rules.dat similarly without criteria.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 3

19 years ago
how odd, this was working for me, I swear.
Status: REOPENED → ASSIGNED
(Assignee)

Comment 4

19 years ago
I figured out what's going on. It's a wierd interaction between the search terms
in the order in which the filter gets created & saved. I've fixed up this code
to be much more robust.

nominate for nsbeta2 - without this fix, if the user forgets to choose a target
folder, the user thinks he/she has entered a bunch of search terms when in fact
everything is lost.
Keywords: nsbeta2
Whiteboard: fix in hand

Comment 5

19 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: fix in hand → [nsbeta2+] fix in hand
(Assignee)

Comment 6

19 years ago
fix is in.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

18 years ago
Seems OK using jun18 m17 commercial builds, linux rh6.0, NT 4.0 and mac OS 9.0

Tried several scenarios, all ok. If I find some outside case which doesn't work
I'll log a separate bug.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.