Confirm closing tab : Save what user added to forms controls, even on HTTPS

RESOLVED DUPLICATE of bug 424872

Status

()

RESOLVED DUPLICATE of bug 424872
11 years ago
8 years ago

People

(Reporter: NicolasWeb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; fr; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; fr; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3

Confirm closing tab action when a user has added content to its controls like text, list, check box... in forms, like in Safari.
If the user want to close the tab, he should be asked to save the control's content.

Reproducible: Always

Steps to Reproduce:
1.Open a web page with a form
2.enter value in text fields
3.select an item on a list box
4.close the tab / window
Actual Results:  
the tab / window close without warning the user.

Expected Results:  
the user should be warned and asked to choose to close tab / window or not, or maybe to save the content for the next session, even if there is only one tab in a window.
(Reporter)

Updated

11 years ago
Severity: normal → enhancement

Comment 1

11 years ago
Note that reopening closed tabs should restore all text you've entered (unless you were on a securely transmitted site as e.g. your online bank's).
Component: Session Restore → Tabbed Browser
QA Contact: session.restore → tabbed.browser
(Reporter)

Updated

10 years ago
Severity: enhancement → normal
(Reporter)

Updated

8 years ago
Blocks: 565517, 565512
No longer blocks: 565512, 565517
(Reporter)

Updated

8 years ago
Summary: Confirm closing tab action / Save value when a user has added content to its controls → Confirm closing tab : Save what user added to forms controls, even on HTTPS
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424872
You need to log in before you can comment on or make changes to this bug.