SMTP over http proxy with connect support

RESOLVED DUPLICATE of bug 264981

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 264981
10 years ago
10 years ago

People

(Reporter: David Maas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (en-US) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 2.0.0.9

A feature that would be very useful is for Thunderbird to support http proxy connect, for retrieving/sending mail (with authentication).

This would be useful on small networks that are too small to be running their own smtp/pop3 servers, but would like all outgoing connections to go through a squid proxy.

Shouldn't be very complicated to add - attempted to do so myself, but could not get Thunderbird to build.

Reproducible: Always

Steps to Reproduce:
Set the network's proxy through Thunderbird advanced preferences, attempt to send or retrieve mail.
Actual Results:  
Thunderbird's proxy support appears to be limited to using an http proxy to retrieve html (images, etc) in mail. Thunderbird will not use the http proxy to connect to smtp or pop3 servers.

Expected Results:  
It would be nice if Thunderbird were to do the following (this is not intended to insult anyone's intelligence):

CONNECT mail.network.net HTTP/1.0
Proxy-Authenication: digest f0b4dc13fe [etc...]

http://muffin.doit.org/docs/rfc/tunneling_ssl.html (CONNECT http method - not quite sure what rfc that belongs to)
http://www.ietf.org/rfc/rfc2617.txt (Basic and digest authentication)

I am aware that HTTP CONNECT method is intended for SSL tunneling, however I still feel that this would be a very worthwhile feature.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 264981
You need to log in before you can comment on or make changes to this bug.