Location bar autocomplete entries do not deselect when typing

RESOLVED DUPLICATE of bug 408723

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 408723
10 years ago
10 years ago

People

(Reporter: bugzilla1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

If I bump the mouse while typing something into the location bar, it highlights the URL that the mouse it over (as expected).  If I continue typing, The URL is not deselected, so pressing enter has unpredictable results (the browser goes to the selected link, not necessarily what the user typed in).  To fix it, the autocomplete entries in the location bar simply need to deselect when a user starts typing.

Internet Explorer 7 has the correct behavior, for comparison.

Reproducible: Always

Steps to Reproduce:
1. Make http://www.google.com and http://www.google.com/ig the first end second autocomplete entry for "googl" (the order does not matter).
2. Type "googl" (without quotes)
3. Move mouse over http://www.google.com/ig
4. Continue typing: "e.com"
5. press enter

Alternatively, do steps 1-3 then:
4. type "e"
5. Press Ctrl+Enter (the shortcut to add http://www. and .com)
Actual Results:  
Firefox goes to http://www.google.com/ig

Expected Results:  
It is expected to go to google.com because that's all that was typed in.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408723
You need to log in before you can comment on or make changes to this bug.