Closed Bug 418596 Opened 14 years ago Closed 14 years ago

SDK build does not work for non-universal build

Categories

(Firefox Build System :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 410637

People

(Reporter: matthew.gertner, Assigned: matthew.gertner)

Details

macbook:~/mozilla/source/HEAD/prismbase/xulrunner Matt$ make -C xulrunner/installer/ make-sdk
Makefile:103: FULL_NSPR_CFLAGS=-I\${includedir}/stable
Creating package directory...
building file list ... rsync: link_stat "/Users/Matt/mozilla/source/HEAD/prismbase/xulrunner/dist/xulrunner-1.9b4pre.en-US.mac-pkg.pkg" failed: No such file or directory (2)
done 

The culprit appears to be http://mxr.mozilla.org/seamonkey/source/toolkit/mozapps/installer/packager.mk#343.   Building an Intel SDK from a tree build using UNIVERAL_BUILD works fine, so perhaps this line is simply not needed.
This should be fixed by the work I've done already in bug 410637.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 410637
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.