Status

defect
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: dougt, Assigned: wtc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Posted patch patch v.1 (obsolete) — Splinter Review
patch that allows building of NSPR on Windows Mobile  (using the mozce shunt library as a dependency).
Attachment #304572 - Flags: review?(wtc)
Comment on attachment 304572 [details] [diff] [review]
patch v.1

I just added _wince.cfg and _wince.h to the NSPR trunk.
I edited the files a little bit, mostly to reformat the
code.  (Our indentation offset is 4, not 2.)  I also
removed code that I believe was not used.  You seem to
have based _wince.h on _winnt.h rather than _win95.h.

But then I saw your changes to prosdep.h and configure.in.
I am confused -- it seems that you're using _wince.cfg
and _win95.h for WINCE.  So _wince.h is not being used!

If you want to use _win95.h for WINCE, that should be
OK, but then you probably should also use _win95.cfg
for WINCE.
Comment on attachment 304572 [details] [diff] [review]
patch v.1

I think merging the windows ce and windows 95 .h/.cfg files makes the most sense.

moving the _ARM_ block from _wince.cfg to _win95.cfg, and fixing up configure.in to point to the right cfg file.


new patch coming up.
Attachment #304572 - Flags: review?(wtc) → review-
Posted patch patch v.2Splinter Review
I am not quite sure about defining UNICODE and _UNICODE_ when MOZ_UNICODE is defined.  I had to do this because our toolchain is not yet defining these And I really want NSPR libs to link to the wide version of window APIS were ever possible. 

this does not require the _wince.h or _wince.cfg
Attachment #304572 - Attachment is obsolete: true
Attachment #304928 - Flags: review?(wtc)
So I should CVS remove _wince.cfg and _wince.h now?
All that work last night for nothing :-)
Comment on attachment 304928 [details] [diff] [review]
patch v.2

Doug, this patch is smaller than I expected.  Is WINCE
very similar to WIN32?  Or is the hard work hidden in
your "shunt" library?

I'm not sure if you can compile NSPR with UNICODE
defined today.  Have you tested that?  I'd be surprised
if it works.

What is this _UNICODE_ macro?

When MOZ_UNICODE is defined, NSPR calls the W versions
of Windows functions directly.  This is why we don't
need to define UNICODE.
sorry about having you review and check in the _wince files.  I am glad we were able to reduce the size of the patch.  Thank you for your suggestion.

The shunt library [1] does provide much of the hard work that is missing.  It basically provides the missing functionality between windows ce and windows 32 that we need.

[1] http://mxr.mozilla.org/seamonkey/source/build/wince/shunt/


Regarding UNICODE:

Our shunt library has supported narrow calls by simply doing the char conversion then calling into the appropriate W function.  We recently have removed this functionality and started changing the callers to use the appropriate wide functions.

I have compiled NSPR w/ this patch on windows mobile.  Builds and links using our shunt library.

_UNICODE_ is another build flag that windows mobile uses.  Pretty strange, but why have only ONE #define, when you can have TWO? ;-)

Duplicate of this bug: 277345
wtc, any luck finding the time to review this last patch?
Comment on attachment 304928 [details] [diff] [review]
patch v.2

going to mark this a dup of 456449
Attachment #304928 - Flags: review?(wtc) → review-
456449 has the latest patch.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.