Closed Bug 418699 Opened 13 years ago Closed 13 years ago

Session restore with multiple http auth prompts fails to load pages

Categories

(Core :: Widget: Cocoa, defect, P1)

x86
macOS
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: nthomas, Assigned: jaas)

References

Details

(Keywords: regression)

Attachments

(1 file)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008022004 Minefield/3.0b4pre

Discovered with today's mac nightly.

STR:
1, New profile
2, Replace default tabset with
     http://people.mozilla.org/~nthomas/test/foo
     http://people.mozilla.org/~nthomas/test/bar
     http://www.google.com (any non-auth page ought to do)
   Cancel each auth prompt (or enter test/moose, doesn't seem to matter)
3, Set Minefield to "Show windows and tabs from last time"
4, Restart Minefield
5, Cancel first auth prompt

Expected results: second auth prompt, first tab to say "Authorization denied"

Actual results: both tabs requiring auth have title "Loading...", don't finish that, and are unresponsive to changing url etc.

You can enter the auth at step 5 and get the same result. 
It only happens if you have multiple tabs requiring auth, one works fine.

This is a regression between the Mac hourly builds of 2008-02-19 17:24 and 18:36.  The checkins in that are 
  http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1203470640&maxdate=1203474959

I can't reproduce on Linux, so I'm guessing it's bug 417124.
Flags: blocking1.9?
Are the auth prompts sheets? Some logic was changed related to how nested sheets work...
Yes, they slide out from the window's titlebar.
Patch coming up, I know what the problem is. This is an issue with sibling sheets, not nested sheets. The second sheet's show code basically never runs because of the way we track visibility for siblings.
Assignee: nobody → joshmoz
Flags: blocking1.9? → blocking1.9+
Attached patch fix v1.0Splinter Review
Attachment #304660 - Flags: review?(hwaara)
Component: Networking: HTTP → Widget: Cocoa
Priority: -- → P1
QA Contact: networking.http → cocoa
Comment on attachment 304660 [details] [diff] [review]
fix v1.0

This looks good to me.
Attachment #304660 - Flags: review?(hwaara) → review+
Attachment #304660 - Flags: superreview?(roc)
Attachment #304660 - Flags: superreview?(roc) → superreview+
landed on trunk
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.