Don't try to discard image data when the image is animating

VERIFIED FIXED in mozilla1.9beta5

Status

()

P2
normal
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: alfredkayser, Assigned: alfredkayser)

Tracking

({crash, perf})

Trunk
mozilla1.9beta5
crash, perf
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
Created attachment 304682 [details] [diff] [review]
V1: Don't start the timer when image is animating

The 'Discard image' function of imgContainer creates a timer (with 45 seconds delay) to discard image data. However, when the image is animating, this timer is cancelled and re-created for every frame that is accessed in the animation.
This is probably the cause of the crash of bug 399925.

A simple solution is to not set the timer when the image is animating (as the discard will never happen). This prevents needless creation and cancellations of the timer, and saves CPU and memory.

A more drastic solution is not to save the discard data for such images, but that is something for another bug.
Flags: blocking1.9?
Attachment #304682 - Flags: review?(pavlov)
(Assignee)

Updated

11 years ago
Blocks: 399925
Assignee: nobody → alfredkayser
Version: unspecified → Trunk
Marking P2 for now, stuart please change priority based on review -- this might need to be P1 if there could be regressions from the change.
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2

Updated

11 years ago
Flags: tracking1.9+ → blocking1.9+

Updated

11 years ago
Attachment #304682 - Flags: review?(pavlov) → review+
Keywords: checkin-needed
Checking in modules/libpr0n/src/imgContainer.cpp;
/cvsroot/mozilla/modules/libpr0n/src/imgContainer.cpp,v  <--  imgContainer.cpp
new revision: 1.67; previous revision: 1.66
done
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9beta5
(Assignee)

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.