Explicitly start shortcut-creating VBS with cscript/wscript

RESOLVED INVALID

Status

Mozilla Labs
Prism
--
minor
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Stuart Langridge, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: http://people.mozilla.com/~mfinkle/prism/prism-0.8-win32.exe

Prism, when creating shortcuts for a newly created web application, does so by writing a temporary VBScript file and then executing it. However, it executes the VBS file by calling Explorer's default action on it without checking what that default action is (or possibly shelling out to "start shortcut.vbs", which is the same thing). My default action for VBS files is "open in Notepad", because then if I inadvertently click on one in an email it won't run and 0wn my machine. Prism should explicitly call cscript/wscript to run VBS files, not rely on the user's default run action.

Reproducible: Always

Steps to Reproduce:
1. Set your default action for VBS files to something other than "Open", such as "Edit".
2. Start Prism and create a web app. The VBS file will appear in Notepad rather than being executed.

Comment 1

10 years ago
There is no longer any VBS used in Prism. Unfortunately there isn't a public build available (you can get the source code from the SVN repository if you want to build it yourself) but there will be soon.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.