message filters "Run Now" option doesn't work on IMAP account

RESOLVED DUPLICATE of bug 184490

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 184490
11 years ago
11 years ago

People

(Reporter: Jacek Pospychala, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: 2.0.0.9 (20071031)

I have a custom filter rule for List-Id field looking like:
"List-Id contains my.favourite.group@google.com"
For such a filter, "Run Now" button doesn't filter messages, however I'm 100% sure rule is correct and filter works for new incoming messages.
"Run Now" button works if I refer to "Subject" field instead of my custom field.

Reproducible: Always

Steps to Reproduce:
1. Open Tools -> Message Filters
2. Create new rule for IMAP account:
a) use "Customize" to define custom header name: "List-Id"
b) set filter rule to "List-Id contains 'some.id@group'" 
3. Make sure you have a message on your IMAP account that fits the rule
4. In Tools -> Message Filters, select newly created rule and press "Run Now" button
Actual Results:  
nothing happens - no messages are filtered.

Expected Results:  
message that fits the rule should be filtered as defined in rule

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 184490
You need to log in before you can comment on or make changes to this bug.