Leading spaces in plain text composer lost

VERIFIED DUPLICATE of bug 40394

Status

()

P3
normal
VERIFIED DUPLICATE of bug 40394
18 years ago
17 years ago

People

(Reporter: BenB, Assigned: akkzilla)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Reproduction:
1. Open plain text composer in Mailnews
2. Enter the following

foo
 foo
  foo

3. Debug|OutputText (or send as plaintext)

Actual result:

foo
foo
foo

Expected result:

foo
  foo
   foo

(RFC 2646 recommends to space-stuff lines starting with ">", "From " and so also
" ". If you read the msg in Mozilla Mailnews, you should see

foo
 foo
  foo

then, but there are currently bugs in the flowed->HTML converter as well.)

Comment 1

18 years ago
Well, expected result when using Debug|OutputText should be:

foo
 foo
  foo

since Debug|OutputText doesn't send the "FormatFlowed" flag to the ContentSink.
(Assignee)

Comment 2

18 years ago
Agreed.  OutputText should give you back just what you typed in (not more
spaces, nor less, but exactly what you typed).  Accepting bug.
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Reporter)

Comment 3

18 years ago
could this be a dup of bug 40394?
(Assignee)

Comment 4

18 years ago
Yes indeed -- sounds like exactly the same problem.  Thanks, Ben!

*** This bug has been marked as a duplicate of 40394 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
verified in 6/15 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.