Closed Bug 418999 Opened 14 years ago Closed 3 years ago

Can't drag link to Thunderbird extension directly into TB Add-on manager

Categories

(Thunderbird :: OS Integration, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: ts.bugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008021704 Minefield/3.0b4pre ID:2008021704

I noticed that I can't drag the Lightning XPI file from neither the FTP page [1] nor the http equivalent from Mac Firefox 3 into Thunderbird's Add-ons Manager window.

This works with Firefox 2 under the same setup.

The filename just glides back from the mouse cursor to it's position in the file list. I don't see this problem on my Windows machines...

[1] <ftp://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-mozilla1.8/mac-xpi/> 

Reproducible: Always
Version: unspecified → Trunk
It works on Linux, at least in some circumstances: dragging the FTP link in comment #0 gave no result, but dragging the "Download now" link on https://addons.mozilla.org/en-US/thunderbird/addon/5373 onto the Thunderbird Add-ons manager popped up the usual "extension install" popup from Tb with the "Cancel" and (after a few seconds) "Install now" buttons.

Browser: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008022201 SeaMonkey/2.0a1pre

Thunderbird version: Thunderbird 2.0.0.13pre (X11/20080222)
Flags: blocking-firefox3?
On OS X, dragging the HTTP URL from Safari worked both in Tb trunk and Fx trunk for me.  Dragging the FTP URL in comment #0 worked in neither, but dragging the FTP URL _on that page_ (http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-trunk/mac-xpi/lightning.xpi) did.  I suspect the trailing slash in comment #0 is messing things up.

In other words, seems to WFM.
The URL in comment #0 links to an FTP page. The URL in comment #2 links directly to a file. Dragging Davids URL directly from this page in
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5pre) Gecko/2008031104 Minefield/3.0b5pre
to Thunderbirds (v2.0.0.12) Add-ons manager does nothing (should bring up the Add-ons installation prompt). It does with Firefox 2.0.0.12.

I can't comment on the situation with Thunderbird 3.

I have no clue like drag and drop works on OS X... Maybe the issue is not directly with Firefox 3, but with Thunderbird 2, that it doesn't react to indicate a valid drop target?
Not blocking on UNCOs ...
Flags: blocking-firefox3? → blocking-firefox3-
Confirming then. This is one of my favorite short-cuts on windows that I can't make work on Mac (the AMO instructions to download first and then find the file from Thunderbird are user-hostile).

On Mac the Thunderbird 2 Add-ons dialog does not accept drops from Firefox 3 or Safari. It would be really nice to get this into a Thunderbird 2 update, especially if there's been a specific fix on trunk (comment 2) that could be easily applied.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted1.8.1.x?
Flags: wanted1.8.1.x?
Not sure why this was filed under Firefox, but seems to work fine for me. I can drag & drop onto Thunderbird's add-on manager and it seems to work ok (though sometimes a bit of a delay due to download times).
Status: NEW → RESOLVED
Closed: 3 years ago
Component: Shell Integration → OS Integration
Flags: blocking-firefox3-
Product: Firefox → Thunderbird
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.