Closed Bug 419082 Opened 12 years ago Closed 12 years ago

absolute positioned wmode transparent Flash object covers relative positioned objects, links, etc.

Categories

(Core :: Layout, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 344027

People

(Reporter: jboyaca, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

An empty area of a Flash object with a wmode of transparent that has been absolute positioned with a DIV over relative or non positioned objects obstructs the objects below.

IE 5.5 had the same issue and resolved in IE 6.  Any areas of an absolute positioned DIV containing a wmode transparent Flash object that do not contain any visible elements allow the content below to be clicked or interacted with.  This is not the case with Firefox 3.0 -

Benefits:  Many Flash ads or Flash navigation are persistent overlays and obstruct the content below the page even though the areas of the transparent Flash are empty.

Reproducible: Always

Steps to Reproduce:
1. try to click on the links in http://wiglo.com/test.html
2. right click on any empty area within the red box
Actual Results:  
http://wiglo.com/test.html

Always happens on Firefox but not on IE 6+

Expected Results:  
Links were not clickable.  Right click demonstrated that the transparent Areas of the Flash object continued to persist over any content below.

The transparent areas of the Flash object should have allowed the content below it to be interactive.
This is AFAIK no bug, transparent doesn't mean that there is nothing.
You have to set the z-index correctly to move the flash under the other content.
Someone how knows the spec better should either confirm this or mark it invalid
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
(In reply to comment #1)
> This is AFAIK no bug, transparent doesn't mean that there is nothing.
> You have to set the z-index correctly to move the flash under the other
> content.
> Someone how knows the spec better should either confirm this or mark it invalid
> 

Thank you Matthias.  The issue is not with z-index being set properly.  It must be higher than the objects below it.  

An example would be a dynamic Flash drop down menu (or a Flash overlay ad as seen on IAB.net) absolutely positioned above content below.  The areas within the Flash that DO have SOLID areas are for interaction.  The areas that are clear or transparent should be able to pass through to the content below.  

This was an issue with IE 5.5 and was resolved in IE 6.0 in order for the online ad industry to successfully introduce this way of adding ad/content type to a web page with transparent Flash in absolute positioned DIVs using FLASH WMODE = TRANSPARENT in 2001.  

Transparent means that there is nothing and therefore the content below it should be clickable.

Please review the link in IE 6+ and on FF 2+ to see what I mean:  http://wiglo.com/test.html
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 344027
You need to log in before you can comment on or make changes to this bug.