Window menu doesn't work

VERIFIED DUPLICATE of bug 419338

Status

()

P2
major
VERIFIED DUPLICATE of bug 419338
11 years ago
11 years ago

People

(Reporter: justdave, Assigned: jaas)

Tracking

Trunk
x86
Mac OS X
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008022004 Minefield/3.0b4pre

On the last few days of nightlies, picking a window from the Window menu doesn't work (the windows are all listed, but picking one does nothing).  I have to Command-` to cycle through the windows to get to the one I need.  Incidently, using the window list from the dock menu does work, just the one on the Window menu within the app doesn't.
Flags: blocking-firefox3?
Assignee: nobody → joshmoz
Component: Menus → Widget: Cocoa
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: menus → cocoa
Flags: blocking1.9?
Stephen found this earlier and said the tryserver builds in bug 404433 fixed it (if I'm remembering correctly). Roc also noticed this problem this morning.
(In reply to comment #1)
> Stephen found this earlier and said the tryserver builds in bug 404433 fixed it
> (if I'm remembering correctly). Roc also noticed this problem this morning.

Yeah, that's the case; I was just about to comment, myself.
(Assignee)

Updated

11 years ago
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
Duplicate of this bug: 419177
(Assignee)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 419338
I've confirmed that this bug is unrelated to the ones fixed by my
patch for bug 404433.

It regressed between the 2008-02-19-04-trunk nightly (which doesn't
have the problem) and the 2008-02-20-04-trunk nightly (which does).

And the problem still happens with the last tryserver build I posted
at bug 404433 (the one containing patch rev 1.2).  It didn't happen
with my rev1 tryserver build because that was made before this bug
regressed.
I just grabbed the nightly build that includes the fix for bug 419338, and can confirm that this *is* fixed by that build.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008022704 Minefield/3.0b4pre
Verified fixed using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008022704 Minefield/3.0b4pre.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.