Closed Bug 419178 Opened 12 years ago Closed 9 years ago

"Port" "Bug 389290 – Bookmarks Menu - dropmarker missing" to SeaMonkey

Categories

(SeaMonkey :: Bookmarks & History, defect)

SeaMonkey 2.0 Branch
x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: sgautherie, Unassigned)

References

Details

(Keywords: regression)

Attachments

(2 files)

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/20070515 SeaMonkey/1.5a] (nightly) (W2Ksp4)

No bug.

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b4pre) Gecko/2008022202 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

Bug.

Bug 389290 comment 10:
{{
[...]
File a SeaMonkey bug for adapting their bookmarksToolbar.css to use
the new binding for the bookmarks menu and bookmarksMenu.js to configure it as
Places does.
}}
Flags: blocking-seamonkey2.0a1?
I see the the dropmarker in the default theme, which theme are you using? Does it still happen on a recent trunk nightly?
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b4pre) Gecko/2008022202
SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/20080819081634 SeaMonkey/2.0a1pre] (home, optim default) (W2Ksp4)

Confirmed with new profile(s):
*Default (Classic) theme.
*Bookmark Manager works fine: has small drop marker.
*(Bookmarks and Personal Toolbar) Menus don't: have no full width line.

NB: Might be related to the other (Thread Manager) regressions !?
I think we won't block Alpha 1 on this UI glitch, but if a patch comes up in the next few days, we're probably good to approve it so it makes the alpha.
Flags: blocking-seamonkey2.0a1? → blocking-seamonkey2.0a1-
Flags: blocking-seamonkey2?
This bug is open but targeted for seamonkey2.0a1, which has been released a long time ago. Please set the target milestone to an appropriate value, "---" if it has no specific target.
Target Milestone: seamonkey2.0a1 → ---
Not blocking 2.0 but would consider a patch. Nominate for wanted 2.1 if you think it is appropriate. Is bug 465323 a dupe of this one?
Flags: blocking-seamonkey2.0? → blocking-seamonkey2.0-
Flags: wanted-seamonkey2.1?
Duplicate of this bug: 465323
(In reply to comment #6)
> *** Bug 465323 has been marked as a duplicate of this bug. ***

Ftr:
{
Comment #3 From  neil@parkwaycc.co.uk   2009-01-29 13:21:45 PDT

This is because toolkit uses -moz-appearance for toolbarbuttons so that you
can't alter the borders to provide drop feedback.

I don't know if or how Firefox provides drop feedback.

Comment #4 From Philip Chee 2009-02-23 06:54:23 PDT

I think they use a drag-drop indicator similar to the way the tab drag&drop
code.
}
Flags: wanted-seamonkey2.0?
Please re-nominate for 2.1 if it doesn't make 2.0
Flags: wanted-seamonkey2.1?
Flags: wanted-seamonkey2.0?
Flags: wanted-seamonkey2.0+
Minimal wallpaper patch for 2.0

 menu.bookmark-item,
 menuitem.bookmark-item {
   border-top: 1px solid transparent !important;
   border-bottom: 1px solid transparent !important;
+  -moz-appearance: none;
 }
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #401832 - Flags: superreview?(neil)
Attachment #401832 - Flags: review?(neil)
Comment on attachment 401832 [details] [diff] [review]
Patch vA1.0 Proposed kwikfix for SM2.0

Oops. Wrong mime type.
Attachment #401832 - Attachment is patch: true
Attachment #401832 - Attachment mime type: application/octet-stream → text/plain
Comment on attachment 401832 [details] [diff] [review]
Patch vA1.0 Proposed kwikfix for SM2.0

Isn't this going to look really ugly on Luna?
> (From update of attachment 401832 [details] [diff] [review])
> Isn't this going to look really ugly on Luna?

I can't tell the difference. The visual appearance does not appear to change with or without the -moz-appearance: none; rule. Does it look really bad on your PC? Perhaps it's just my graphics card.
Attachment #402365 - Flags: ui-review?(neil)
Comment on attachment 401832 [details] [diff] [review]
Patch vA1.0 Proposed kwikfix for SM2.0

It might look passable with Luna but it's no good on a typical Linux theme.
Attachment #401832 - Flags: superreview?(neil)
Attachment #401832 - Flags: review?(neil)
Attachment #401832 - Flags: review-
> It might look passable with Luna but it's no good on a typical Linux theme.

How about I use:
:-moz-system-metric(windows-classic) and :-moz-system-metric(windows-default-theme)
To limit the application, or is this too hacky?
Assignee: philip.chee → nobody
Status: ASSIGNED → NEW
Attachment #402365 - Flags: ui-review?(neil)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101213 SeaMonkey/2.1b2pre

Appears to be WFM due to the move to Places Bookmarks.

WONTFIX for the SeaMonkey 2.0 branch.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Version: Trunk → SeaMonkey 2.0 Branch
You need to log in before you can comment on or make changes to this bug.