Can't see Friends section in Facebook

VERIFIED FIXED

Status

()

Core
JavaScript Engine
P2
normal
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: cilias, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +
in-testsuite +
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 305255 [details]
screenshot

For about a week now, viewing the Friends section in Facebook does not display any friends.
Here's what the error console says:

Error: this.parse is not a function
Source File: http://static.ak.facebook.com/rsrc.php/44:84049/js/common.js.pkg.php?c=44:57:84049
Line: 266


According to <http://forums.mozillazine.org/viewtopic.php?p=3266965#3266965>, this first started in the 20080215_1847 nightly.

Updated

10 years ago
Keywords: regression
Version: unspecified → Trunk
Works: 20080215_1829_firefox-3.0b4pre.en-US.win32
Broken: 20080215_1905_firefox-3.0b4pre.en-US.win32

Checkins to module PhoenixTinderbox between 2008-02-15 18:29 and 2008-02-15 19:04 : 
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1203128940&maxdate=1203131099

Due to bug 395993. After clicking about on the tabs in the Friends section the error console reports things like:

Error: this.parse is not a function
Source File: http://static.ak.facebook.com/rsrc.php/44:84049/js/common.js.pkg.php?c=44:57:84049
Line: 266

Security Error: Content at http://static.ak.facebook.com/rsrc.php/82858/js/lib/util/quickling.js?57:82858 may not load data from http://www.facebook.com/friends/.

Error: Quickling.debug is not a function
Source File: http://static.ak.facebook.com/rsrc.php/82858/js/lib/util/quickling.js?57:82858
Line: 19

Security Error: Content at http://static.ak.facebook.com/rsrc.php/82858/js/lib/util/quickling.js?57:82858 may not load data from http://www.facebook.com/friends/.

Error: Quickling.debug is not a function
Source File: http://static.ak.facebook.com/rsrc.php/82858/js/lib/util/quickling.js?57:82858
Line: 19

Security Error: Content at http://static.ak.facebook.com/rsrc.php/82858/js/lib/util/quickling.js?57:82858 may not load data from http://www.facebook.com/friends/.

Error: Quickling.debug is not a function
Source File: http://static.ak.facebook.com/rsrc.php/82858/js/lib/util/quickling.js?57:82858
Line: 19
Blocks: 395993
Flags: blocking1.9?

Updated

10 years ago
Duplicate of this bug: 419139
As far as I can tell, my patch in bug 418069 fixes this.

Updated

10 years ago
Duplicate of this bug: 419775
Keywords: relnote

Updated

10 years ago
Depends on: 418069
Flags: blocking1.9? → blocking1.9+

Updated

10 years ago
Flags: tracking1.9+ → blocking1.9+
Priority: -- → P2
(Reporter)

Comment 5

10 years ago
Fixed as a result of bug 418069.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Bug 418069 has tests for this, and I've also verified it's fixed using:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008030304 Minefield/3.0b4pre

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008030305 Minefield/3.0b4pre

-and-

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008030304 Minefield/3.0b4pre
Status: RESOLVED → VERIFIED
Keywords: relnote
Flags: in-testsuite+
Flags: in-litmus-
You need to log in before you can comment on or make changes to this bug.