Closed Bug 419252 Opened 12 years ago Closed 12 years ago

Javascript causes firefox freeze in some html pages after about 5 minutes

Categories

(Core :: General, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 335256

People

(Reporter: fred_spamfighter-mozaddon, Unassigned)

References

()

Details

(Keywords: hang)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

Hi, (sorry for my english, i'm french)

I have a bug in safe mode with FF2.0.0.12 and FF3b3 (java RE 6u3 and 6u4). It is related to javascript. When JS is disabled, everything's fine. IE detects some errors but doesn't freeze or crash.

Test it: especially on this page http://www.laguitare.com/result_page.php?evt_type=SL&evt_id=0,
after about 3 or 5 minutes, firefox freezes and its process increases about 50% of my intel dual core cpu. I have to kill process or close firefox in the taskbar (close button doesn't repond).

Error Console reports:

banUrl[actualBan] has no properties
Fichier source : http://www.laguitare.com/result_page.php?evt_type=SL&evt_id=0
Ligne : 44

Everything's fine for a while but after few minutes this error seems to be looped in the console and ff freezes

Reproducible: Always

Steps to Reproduce:
1.enable javascript (plugin Java(TM) Platform SE 6 U4 or U3) and visit http://www.laguitare.com/result_page.php?evt_type=SL&evt_id=0
2.open error console and monitor your cpu activitie about firefox process

Actual Results:  
3.wait few minutes and the ff should freeze and the cpu increase

Expected Results:  
FF should behavior like IE: report the error without freezing
Version: unspecified → 2.0 Branch
Confirmed. This is not a (recent) regression; I see it also in Firefox 1.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: hang
Product: Firefox → Core
QA Contact: general → general
Version: 2.0 Branch → unspecified
Ok Ria. So, can you vote so that the bug is more visible? Are you working on mozilla developement?
(In reply to comment #2)
>
No, I'm a tester/triager. I confirmed it because I could reproduce it with a clean installation and a new profile. The keyword "hang" and the changed product and component should generate some attention, if it is important enough. I haven't jet seen the problem in the wild, so maybe it is an isolated incident, just a bad javascript. Patches are always welcome, everyone who passes by can do an attempt to fix it :).
See also: http://kb.mozillazine.org/Firefox_hangs


"getBanId" sets up a call to itself at regular intervals, "TimeId" is
never clearInterval'ed.  The performance is worse in Firefox since
the function then throws an error so "banId == -1" is always true.


function getBanId(cible){
	if(banId == -1){
		var exec = "getBanId('" + cible + "');" ;
		TimeId = setInterval(exec, timeout) ;
	}
	
	var target = '' + cible ;
	obj = MM_findObj(target) ;
	obj.src = banUrl[actualBan] ;
	banId = banIdLoaded[actualBan] ;
	
	if(actualBan == (nbBandeaux-1))	{
		actualBan = 0 ;
	} else {
		actualBan = actualBan + 1 ;
	}

}
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 335256
You need to log in before you can comment on or make changes to this bug.