Closed Bug 419274 Opened 15 years ago Closed 15 years ago

:nth-child() pseudo-class selector is not implemented

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 75375

People

(Reporter: nm127, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; hu; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; hu; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3

The text has red backround instead of green at test case http://www.w3.org/Style/CSS/Test/CSS3/Selectors/current/xhtml/full/flat/css3-modsel-28.xml


Reproducible: Always

Steps to Reproduce:
1. Open test case at http://www.w3.org/Style/CSS/Test/CSS3/Selectors/current/xhtml/full/flat/css3-modsel-28.xml

Actual Results:  
The backgrounds are red.

Expected Results:  
The backgrounds are green.
The screenshot was created with:
Mozilla/5.0 (X11; U; Linux i686; hu; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3
Component: General → Style System (CSS)
Product: Firefox → Core
QA Contact: general → style-system
Depends on: 75375
Summary: W3C CSS3 Selector test fails: ":nth-child() pseudo-class (ID #28)" → :nth-child() pseudo-class selector is not implemented
Version: unspecified → Trunk
Flags: blocking1.9?
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Flags: blocking1.9?
OS: Linux → All
Hardware: PC → All
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #3)
> 
> *** This bug has been marked as a duplicate of bug 75375 ***
> 
Gavin, is it just me or does this bug still have a status of "New"?
(In reply to comment #4)
> Gavin, is it just me or does this bug still have a status of "New"?

I reopened it after seeing that dbaron had already marked the dependency (which is visible in https://bugzilla.mozilla.org/show_activity.cgi?id=419274 ).
Status: NEW → RESOLVED
Closed: 15 years ago15 years ago
No longer depends on: 75375
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.