right click on "get addons" tab's links should open popup menu, not webpage

RESOLVED DUPLICATE of bug 414628

Status

()

RESOLVED DUPLICATE of bug 414628
11 years ago
11 years ago

People

(Reporter: kontakt, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b4pre) Gecko/2008022404 Fedora/8 (Werewolf) Minefield/3.0b4pre
Build Identifier: 

right click on links in "get addons" tab works exactly like left click.

this is wrong.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
same behavior for left and right click

Expected Results:  
popup menu on right click

this bug shouldn't land here, but this issue is shared by both thunderbird and firefox.
Component: Widget: Gtk → Extension/Theme Manager
Product: Core → Firefox
QA Contact: gtk → extension.manager
Version: unspecified → Trunk
(Reporter)

Comment 1

11 years ago
and the popup menu should have "copy link's url" among others.
We use the generic toolkit widget so this applies to all uses of that widget in the app. If we want to do it we should do it for al not just some.
Component: Extension/Theme Manager → XUL Widgets
Product: Firefox → Toolkit
QA Contact: extension.manager → xul.widgets
See bug 414628. I don't think we want to try and create a generic context menu for this widget.
(Reporter)

Comment 4

11 years ago
Those bug was not touched from januar.
I don't see how that's relevant. This bug is a duplicate, except it proposes a different solution that I think is WONTFIX. 
(Reporter)

Comment 6

11 years ago
Maybe just "void(null) for right click?
That would be bug 414628.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414628
You need to log in before you can comment on or make changes to this bug.