bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

drag & drop of ics file onto the calendar-switch-button doesn't import UID (events duplication)

VERIFIED DUPLICATE of bug 450653

Status

Calendar
Lightning Only
--
minor
VERIFIED DUPLICATE of bug 450653
11 years ago
10 years ago

People

(Reporter: Przemyslaw Bialik, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.9) Gecko/20071031 Lightning/0.8pre ID:2008022321 Thunderbird/2.0.0.9 ID:2007103104

Drag & drop of ics file onto the calendar-switch-button doesn't import UID (leads to events duplication).

Reproducible: Always

Steps to Reproduce:
1. Drag & drop ics file (with event ;) onto the calendar-switch-button
2. Save event
3. Repeat step 1-2 with the same ics file
Actual Results:  
Duplicate event created.

Expected Results:  
Alert: "The event you are trying to import already exists in your calendar"

If it's updated event beside previous message Update and Cancel buttons should be available.

Duplicates are created because UID from ics file is not being used in such drag & drop event creation / "import".
(Reporter)

Comment 1

11 years ago
There is somewhat related Bug 325449 but not a duplicate.
To trigger the ics import directly drag and drop the .ics file to the main calendar view. The mode toolbar buttons will create a new event from the task/email/file dragged onto them.
(Reporter)

Comment 3

11 years ago
Yes I know about the first part but thanks to Bug 403768 I will be using drag & drop of e-mail ics attachment on to the calendar-switch-button to import events and not create new ones.
Also if d'n'd to the main calendar view imports then why not import on calendar-switch-button, saving ics only to drag it later to calendar view is not nice.
Bug 247764 comment #18 could be also a workaround for this bug but it is not yet implemented.

Comment 4

10 years ago
This bug was filed first, but since there's been more extensive discussion in bug 450653, I'm marking this one as the "DUP".
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 450653
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.