Pop Up Status row above remains, but if option to hide Msgs is taken, then it is gone from the status bar.

RESOLVED WORKSFORME

Status

()

Firefox
Preferences
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: tom@dfamily.com, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

Every time I open the web page a whole row opens to NAG me I have Pop Ups.  Obviously, I need to allow them so it will quit nagging.  Only those web sites I have ALLOWED do Not Nag me.

On the bottom there WAS a Pop Up Status button.  If you do a Right mouse on it there are some options.  One was something like "do not show pop up message".  Something like that.  You see, once I took that option (hoping the nag ware above would go away), the Pop Up status icon left the status bar and it never comes back.  (Sorry I can't be exact on the message and option text.  I didn't know the text was going to disappear forever.)

As far as I can tell, the only place to set any of these Pop Up options is from the Pop Up icon on the Status bar if it ever comes back.

Reproducible: Always

Steps to Reproduce:
1. Open a Web Page with a Pop Up you do NOT want to open such as http://www.newsmax.com/insidecover/
2. Make the Pop Up Status bar go away without having to close it every time.
3. Make the Pop Up Icon show back up on the Status bar once you have mistakenly told it to go away.
4. I think there were some other options on the Pop Up Icon. They need to be available somewhere else as well. 
Actual Results:  
The Pop Up Status icon left the Status Bar and will not come back.

Expected Results:  
The Pop Up Nag Ware ribbon above the web page would go away and stay away and the Pop Up icon on the status bar would remain.

If we said No Pop Ups except for these exceptions, then we do not also want the nag ware.  An icon on the status bar is sufficient.  If we have to have a 2nd list, one that says "And I REALLY MEAN it for these guys" so the Nag Ware knows it should be silent and out of mind, then fine.
Tools | Options | "Content" tab -> "Block pop-up windows" (there's even a "Manage Exceptions" button to the right.

-> works for me
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

11 years ago
Stephen, Do you have a PopUp icon on the status bar?
Did you click on it and take some of the options?
Did the PopUp Icon on the Status bar go away?

If it did, how did you get it back?

The block function does work. I never said it didn't.  I said if I did not allow PopUps the PopUp Nag ribbon will display instead every time and if I took the wrong option on the PopUp Icon on the Status bar, the Pop Up icon on the Status bar goes away and those options which were ONLY available on the PopUp icon on the Status bar are gone and seemingly unchangeable.
(Reporter)

Comment 3

11 years ago
I may be confusing things here.  The Pop Up ribbon at the top works correctly.  I just plastered the Nag thing on it as a means to perhaps influence its implementation.

*The Issue* is to remove the Pop Up icon from the Status bar and then to get it back again.  It may be as simple as modifying the help so we can figure out how to get it back.
OK; then change the value of privacy.popups.showBrowserMessage in about:config to false.
to true, rather.

Sigh.
(Reporter)

Comment 6

11 years ago
Wow!
I'm impressed.
(In reply to comment #6)
> Wow!
> I'm impressed.

Did that work for you?
(Reporter)

Comment 8

11 years ago
It put the icon back on the Status bar.  So, for me, yes.

For everyone else, no.  Not unless those instructions (about:config) are put in the Help or something to get it back.  That probably isn't a good idea.

I don't know if my Firefox has been updated.  I didn't think so, but the PopUp "nag ribbon" BUTTON at the top now says "options".  Click on it and I get the menu options I had on the PopUp icon on the Status bar.  That wasn't there this weekend.  Not unless I'm dreaming.
(In reply to comment #8)
> It put the icon back on the Status bar.  So, for me, yes.
> 
> For everyone else, no.  Not unless those instructions (about:config) are put in
> the Help or something to get it back.  That probably isn't a good idea.
> 
> I don't know if my Firefox has been updated.  I didn't think so, but the PopUp
> "nag ribbon" BUTTON at the top now says "options".  Click on it and I get the
> menu options I had on the PopUp icon on the Status bar.  That wasn't there this
> weekend.  Not unless I'm dreaming.

The preference value I mentioned in comment 4 and comment 5 resets what you noted reappeared in comment 8.  The notification bar is designed to be unobtrusive, but apparently it's too unobtrusive such that you didn't notice you had chosen the option "Don't show this message when popups are blocked."
You need to log in before you can comment on or make changes to this bug.