If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No find or other keyboard response in acroread (Adobe Acrobat) pdf plugin

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
10 years ago
7 years ago

People

(Reporter: gene smith, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-07-30])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

When plugin acroread (Adobe Acrobat) is displaying a pdf file keyboard entry is disabled. Can't do find or page up/down. Only mouse responds on page. Not sure when this stopped working. Loaded newes rpm version of acroread with same result. 
Mouse access continues to work, but for me the biggest problem is that search (ctrl-f) access is disabled. This worked with default version of firefox installed with fedora 8 but at some point the keyboard access in pdf became disabled.

Reproducible: Always

Steps to Reproduce:
1.Open a pdf file into firefox
2.Do crtl-f to search, type into search box, or pg dn with keyboard
3.Nothing happens
Actual Results:  
No keyboard response in pdf file with acroread plugin

Expected Results:  
When crtl-f hit, should allow typing in find box. Or when pg up/dn hit page should scroll

Possibly an acroread bug but tried two version and actually the 1st version worked at least with fedora 8 as originally installed.

Also, possibly a bug in fedora 8?

Also, possibly I should have searched bugs for "pdf" but didn't so sorry if this is a duplicate.
(Reporter)

Comment 1

9 years ago
Well no additional comments after several months. Possibly it is just me. However, I have the same problem on another fedora 8 installation. My only solution is to uninstall the plug-in file. Now acroread runs stand-alone instead of plugged in to firefox. Actually like this better, so this issue is a feature, not a bug! Now the keyboard works when looking at a pdf.

Comment 2

9 years ago
I have the same problem in Fedora 8.

Comment 3

9 years ago
This is actually an issue with the ndispluginwrapper in Fedora 8:

https://bugzilla.redhat.com/show_bug.cgi?id=432673
(Reporter)

Comment 4

9 years ago
As Per wrote, this works around the problem in f8:

<quote>
Yes, apparently this is hitting the nspluginwrapper bug.  I added nppdf* to the
IGNORE_WRAP= string in /etc/sysconfig/nspluginwrapper, then ran: 
mozilla-plugin-config -r
mozilla-plugin-config -i

Now it works like it's supposed to.
<end quote>

This indicates it is fixed in f9:
https://bugzilla.redhat.com/show_bug.cgi?id=388961

This firefox bug should be closed and marked as INVALID.
This bug was originally reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.6 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Whiteboard: [CLOSEME 2010-07-30]
Version: unspecified → 2.0 Branch
No reply, INCOMPLETE. Please retest with Firefox 3.6.8 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.