Third-party themes broken on Vista due to chrome override additions from bug 416531

RESOLVED DUPLICATE of bug 419319

Status

()

P1
major
RESOLVED DUPLICATE of bug 419319
11 years ago
11 years ago

People

(Reporter: reed, Unassigned)

Tracking

({regression})

Trunk
Firefox 3 beta4
x86
Windows Vista
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
[Spin-off from bug 416531, comment #27]

Ed Hume <ehume@pshrink.com> says:

"I believe you have chosen an unwise way to proceed with this.

Please look at this thread:

http://forums.mozillazine.org/viewtopic.php?t=630829

Basically, you have broken every third party theme for the Vista environment.

I proposed an addition to chrome.manifest that would reverse the
classic.manifest overrides and restore our themes to working condition. It did
not work.

What this means is that all themers will have to:

1. Discover from unhappy Vista users that certain buttons - some obvious, some
obscure - do not work.

2. Figure out what is wrong.

3. Figure out how to fix it.

In the short term, we themers will have to duplicate, for each of our themes,
each of the files you have reassigned. Each developer, each theme. That's a lot
of extra MB running through Moz Update, and a lot of man-hours spent finding,
figuring and fixing by all the many theme developers.

So I ask: why break everybody else's themes? 

Is there another method?

One thing that occurs to me is that you could split the Firefox builds. You
have three now - Linux, OSX and Windows. You could have four: Linux, OSX,
Windows and  Vista. OK, I know that's a bit harsh, but what you are doing to
third party developers is also harsh; don't forget, we haven't heard from
extension developers yet.

Or you could do something else. Like fixing the chrome overrides bug. Or -
heaven forfend - leave the current default as the default, and supply the Aero
theme as an Add-on at AMO.

Or even package the Aero theme as an add-on that ships with each windows build.
That way, a user - even a non-Vista user - could choose the Aero theme from the
Add-ons window. Heck, you could even use your classic.manifest file to choose
which theme would be the default, based on OS. This would give the Vista users
the Aero experience ab initio without breaking everybody else's themes.

But please withdraw your current fix."
Flags: blocking-firefox3?
(Reporter)

Updated

11 years ago
Priority: -- → P1

Comment 1

11 years ago
IMO we should ship just one theme for all Windows versions i.e. the Aero theme. It is better than the XP theme in all respects. XP theme curently looks nothing more than a faded, dumbed down version of the Aero theme. Aero theme is excellent (except for the Stop button which is better in the XP theme).
(Reporter)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 419319
(Reporter)

Updated

11 years ago
No longer blocks: 416531
(Reporter)

Updated

11 years ago
Flags: blocking-firefox3?
Flags: in-litmus?

Comment 3

11 years ago
Marcia: Is there any special reason to set in-litmus? on this bug which is a dupe of bug 419319?  I think this flag should be set on that bug instead.
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.