Animated GIF set to play once only shows last frame on javascript mouseover

VERIFIED DUPLICATE of bug 17126

Status

()

Core
JavaScript Engine
P3
normal
VERIFIED DUPLICATE of bug 17126
18 years ago
17 years ago

People

(Reporter: Dave Gileadi, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m16) Gecko/20000607
BuildID:    2000060720

I've created a page that shows a normal image, and on a mouseover it switches to
an animated gif image, which is (internally in the gif image) set to only play
once.  I've used Dreamweaver's javascript code, which is pretty standard javascript.

When the mouse is placed over the image the first time, the animated gif plays
through all the frames normally.  However, every mouseover after that, the
animated gif only displays its last frame, instead of playing the entire
animation again.

When the the web page is refreshed (by clicking the browser's refresh button)
the error persists--the last frame is still the only one that displays on a
mouseover.

Reproducible: Always
Steps to Reproduce:
1. Create an animated gif that only plays (cycles through its frames) once.
2. Set it to display on a javascript mouseover (as the "on" image of the mouseover).
3. Mouse over the image two or more times.  Every time after the first, the
image will display the last frame only.

Actual Results:  The mouseover image only displays its final frame.

Expected Results:  The mouseover image should display all of its frames when
moused over--the animation should play all the way through.

Comment 1

18 years ago
This is a dup of bug 17126 but I can't resove it.

Comment 2

18 years ago
yup, does seem to be a dup.  Thanks Michael!

*** This bug has been marked as a duplicate of 17126 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
v. dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.