Need to catch Cocoa exceptions in Mac file handlers

RESOLVED DUPLICATE of bug 419390

Status

RESOLVED DUPLICATE of bug 419390
11 years ago
3 years ago

People

(Reporter: stanshebs, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
The Mac-specific framework calls uriloader/exthandler/mac can potentially throw Cocoa exceptions that are not caught within the framework, and thus need to be wrapped in @try-blocks like other Cocoa code.
(I don't think the InternetConfig calls need it though, is self-contained.)
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 419390
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.