Closed Bug 419399 Opened 12 years ago Closed 9 years ago

Revisit quota logic in jsarena.c, after arenas enlarged by malloc_usable_size

Categories

(Core :: JavaScript Engine, defect, P4, minor)

defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: moz, Assigned: moz)

References

Details

(Keywords: memory-footprint)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3
Build Identifier: 

After patches from bug 415967, it is possible to use more memory in an arena than was asked for (by specifying an 'arenasize').

Should we "bill" for the memory gifted to us by malloc_usable_size()?  Previously, we were consuming the memory but not using it and not being billed for it.  Currently, we are consuming the memory and using it but not being billed for it.  Reconsider this.

keywords: quota, quotap, arena, arenasize

Reproducible: Always
Assignee: general → moz
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Status: NEW → ASSIGNED
Priority: -- → P4
I have had to include this fix into my patch for bug 415967.  Otherwise, I was getting an error in e4x/Regress/regress-394941.js.  Fortunately, "correct" billing was easy to implement.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Best to make this bug depend on that one, then. Technically this bug is not fixed (it's not a big deal, but standard bug protocol).

/be
(In reply to comment #2)
> Best to make this bug depend on that one, then. Technically this bug is not
> fixed (it's not a big deal, but standard bug protocol).
That makes sense.  Thanks, Brendan.
Depends on: 415967
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Depends on: 420476
Status: REOPENED → ASSIGNED
Keywords: footprint
Robin, with bug 415967 fixed, does this bug have a purpose anymore?
Bug 415967 was not actually fixed. It went stale, and someone marked it "resolved invalid".

So, yes, this bug still has a purpose, because the patch for 415967 did not go in.
There's no patch here, and bug 415967 comment 123 explains by bug 415967 isn't needed.  I will WONTFIX this.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.