Proxy authentification is not re-used properly

RESOLVED DUPLICATE of bug 230190

Status

()

RESOLVED DUPLICATE of bug 230190
11 years ago
11 years ago

People

(Reporter: Nicolas.Mailhot, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.9b4pre) Gecko/2008022104 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.9b4pre) Gecko/2008022104 Minefield/3.0b4pre

I use firefox behind a corporate proxy that requires authentification. When all works firefox displays an initial password prompt for the password manager, then a pre-filled authentication dialog for the proxy. Then you're done all should work.

Unfortunately, Firefox often gets hopelessly confused (don't know if the proxy drops the connection, is in a round-robin server pool, or something else). Anyway instead of re-using the already provided proxy auth, or displaying a new pre-filled auth dialog, Firefox pops up a new empty auth dialog.

This is very annoying and time-wasting.

Sometimes it happens on boot (extension update check?) sometimes it happens in every browser tab (ten auth dialogs competing for being raised are *not* fun), sometimes it happens for extensions like ForecastFox (when it tries to get a weather update).

Trying to fill those dialogs is hopeless (they re-spawn faster than hell). Clicking cancel cancel cancel like mad then doing a refresh usually restores sanity (at the cost of losing data that was being inputed as a refresh is not always neutral). In any case it makes people laugh Firefox out faster than you can say it.

Please fix Firefox proxy management to be less auth-dialog-happy

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 230190
You need to log in before you can comment on or make changes to this bug.