Lightning + CalDAV does not support FREEBUSY ( free or busy "show time as" status )

VERIFIED DUPLICATE of bug 415376

Status

VERIFIED DUPLICATE of bug 415376
11 years ago
11 years ago

People

(Reporter: e.s34, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: -//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN

Hi, 

Our Company needs shared calendars with Lightning. 

I just installed Apple Calendar Server on a Ubuntu Server, and it is running. 

I can create, share, etc many calendars. But it seems free/busy status does not work. It is not written in ics files (see example in "additional information").

I tested with TB 2.0.0.9 and Lightning 0.7 and 0.8pre

Reproducible: Always

Steps to Reproduce:
1. create new event with free or busy status
2. check result in calendar an/or ics file

Actual Results:  
no information about free busy status

Expected Results:  
can view and manage free busy status

BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:/mozilla.org/20070129_1/Europe/Paris
X-LIC-LOCATION:Europe/Paris
BEGIN:STANDARD
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=10
TZNAME:CET
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=3
TZNAME:CEST
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20080225T154803Z
LAST-MODIFIED:20080225T155105Z
DTSTAMP:20080225T155105Z
UID:ade56f0c-36c4-4df4-8c35-48e2c5d59b0e
SUMMARY:https busy
CLASS:PUBLIC
DTSTART;TZID=/mozilla.org/20070129_1/Europe/Paris:20080213T170000
DTEND;TZID=/mozilla.org/20070129_1/Europe/Paris:20080213T180000
TRANSP:TRANSPARENT
X-MOZ-GENERATION:2
END:VEVENT
END:VCALENDAR
(In reply to comment #0)
> TRANSP:TRANSPARENT

Seems to be there, at least in the ics sample you posted. See RFC 2445 section 4.8.2.7 Time Transparency.

Or do you request support for VFREEBUSY components? -> Bug 415376.

Comment 2

11 years ago
Current Sb/Ltn nighties support caldav-sched style freebusy, as will 0.8, on Apple (Darwin) Calendar Server and some other CalDAV servers (see http://greenbytes.de/tech/webdav/draft-desruisseaux-caldav-sched-04.html for information on caldav-sched). This support gives you freebusy information for attendees as you add them to an event; no .ics or .ifb file is produced. As you add them to an event you need to use the cuaddr (which should be in the form of an email address) defined for their account in your accounts XML file or whatever other directory you are using.

To the extent that this bug is about caldav-sched, it is invalid. Since reporter mentions .ics files I'm suspecting it's about VFREEBUSY components, so I'm duping this bug against bug 415376.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 415376

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.