page-break-before:always not works in nested tables

RESOLVED DUPLICATE of bug 136714

Status

()

--
major
RESOLVED DUPLICATE of bug 136714
11 years ago
9 years ago

People

(Reporter: pault, Unassigned)

Tracking

({css2})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; InfoPath.1; .NET CLR 2.0.50727)
Build Identifier: Firefox 3 build 3

not works in nested tables:
<body>
		<table>					
			<tr><td>					
				<table>
					<DIV style="page-break-before:always;">
					<tr  style="page-break-before:always;">
						<td>40</td>
					</tr>						
					</DIV>
					<DIV style="page-break-before:always;">					
					<tr  style="page-break-before:always;">
						<td >&nbsp;Page 2</td>
					</tr>																								
					</DIV>
					<tr>
						<td>40</td>
					</tr>						
				</table>
			</td></tr>
		</table>		
	</body>

But works in 
 <body>
				<table>
					<DIV style="page-break-before:always;">
					<tr  style="page-break-before:always;">
						<td>40</td>
					</tr>						
					</DIV>
					<DIV style="page-break-before:always;">					
					<tr  style="page-break-before:always;">
						<td >&nbsp;Page 2</td>
					</tr>																								
					</DIV>
					<tr>
						<td>40</td>
					</tr>						
				</table>
	</body>


Reproducible: Always

Steps to Reproduce:
1. <body>
				<table>
					<DIV style="page-break-before:always;">
					<tr  style="page-break-before:always;">
						<td>40</td>
					</tr>						
					</DIV>
					<DIV style="page-break-before:always;">					
					<tr  style="page-break-before:always;">
						<td >&nbsp;Page 2</td>
					</tr>																								
					</DIV>
					<tr>
						<td>40</td>
					</tr>						
				</table>
	</body>

2.
3.
Actual Results:  
in print priview shows only first page
and prints only the first page too
(Reporter)

Updated

11 years ago
Keywords: css2

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 136714
You need to log in before you can comment on or make changes to this bug.