Bookmarks lose their tags when moved to different folder

RESOLVED DUPLICATE of bug 415389

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED DUPLICATE of bug 415389
11 years ago
9 years ago

People

(Reporter: Topher Hunt, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3

I have several bookmarks tagged as "To Read". When I reorganize my bookmarks in the bookmarks library (which is slow because I cannot drag-and-drop bookmarks onto folders for some reason), the bookmarks lose their tag association.

Reproducible: Always

Steps to Reproduce:
1. Create bookmark with a tag.
2. In the bookmarks library, select this bookmark and CTRL + X to cut.
3. Select a new folder in the bookmarks library, then press CTRL + V to paste. Observe that the associated tag has been lost.
Actual Results:  
The tags were no longer present.

Expected Results:  
The tags would ideally be preserved on cut and paste and moving around of bookmarks.

I'm using Ubuntu Gutsy on an Inspiron 1520 laptop. I don't know if that makes any difference. Noticeably the bookmarks library also has other problems, and I haven't tested whether Firefox 3b3 has these problems in other operating systems as well.
Component: Bookmarks → Places
QA Contact: bookmarks → places
Whiteboard: [DUPEME]
Version: unspecified → Trunk
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008022504 Minefield/3.0b4pre

Can confirm.

But this isn't happening when drag'n'droping bookmark into other folder

Comment 2

11 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008022611 Minefield/3.0b4pre

Can also confirm on Ubuntu 8.04 Hardy Alpha 5.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Whiteboard: [DUPEME]
Duplicate of bug: 415389
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.