Download manager feels wrong in windows, e.g right click shouldn't be used for everything

VERIFIED WONTFIX

Status

()

Toolkit
Downloads API
--
enhancement
VERIFIED WONTFIX
11 years ago
10 years ago

People

(Reporter: Damian Shaw [Quan], Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Removing any kind of menu bar or app bar makes the download manager look very un-windows like. It seems like an unneeded GUI change when theirs an emphases on OS integration.

Right click is supposed to bring up contextual options, when you currently right click on any download an option you get it:

"Clear list"

This is clearly a global function for the download manager and needs to be presented as such in some menu / app / tool bar.
This is just a dupe of bug 400495 right?
(Reporter)

Comment 2

11 years ago
Only if bug 400495 makes the download manager look like it belongs in windows for windows again and not a mac application on windows. I was really just giving an example with "Clear list".

Comment 3

11 years ago
I don't think it's "un-Windows-like" for a subwindow to lack a menubar.  It's just wrong (on all platforms) to have non-contextual commands (only) in a context menu.
(Reporter)

Comment 4

11 years ago
I'd agree with you when a subwindow is obviously a subwindow, but many times I have the download window open without the main Firefox window open and it looks in place in Firefox 2. Normal application subwindows are not normally open without their parent right behind them, so it look normal, they also usually keep the graphical style theme of the parent window, so again look o.k.

I no longer keep the download window open, because it neither looks like it belongs to the Firefox main window, nor does it look at home on my desktop sitting on its own.

If most people don't think this, fair enough, I felt fairly strongly about how poor it looks and I know people who agree it doesn't look windows-like. But if the majority like it, fair enough.
(Reporter)

Updated

11 years ago
Summary: Download manager feels wrong in windows (right click shouldn't be used for everything). → Download manager feels wrong in windows, e.g right click shouldn't be used for everything

Comment 5

11 years ago
Created attachment 311269 [details]
Add-ons-like UI for download manager

These 2 have a somewhat similar appearance and purpose, so they should behave similarly as well IMO.
(Reporter)

Comment 6

10 years ago
To validate this bug, I would like to make some key points on why it "feels" wrong.

[*] No frame
[*] No buttons
[*] Global function in context menu
[*] No visual representation between columns or rows

All of the above I'd expect to see in any Windows app. Even if the representation between the columns or rows are made in the frame.
I don't agree that this is needed.  The frame isn't exactly useful, the buttons you're suggesting are a) the double click action and b) secondary actions, global functions absolutely exist in many apps (i.e. Select All is a global function, there's a few other important ones that I enumerated in the clear list bug), and the visual distinctions between rows matters, but not columns, already exist.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX

Updated

10 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

10 years ago
I don't agree with most of your logic there, but I think this bug is invalid now as most the issues are resolved. 

I will make another bug about it not feeling very native inside windows as it has no proper frame, but that would of been fixed in bug 429862 but not activity on it recently :=/
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.