Weblinks appear as %-escaped code sequences instead of punycode in saved pages

UNCONFIRMED
Unassigned

Status

()

Firefox
General
UNCONFIRMED
10 years ago
7 years ago

People

(Reporter: utf16, Unassigned)

Tracking

3.6 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

When you try to save a page that contains punycode links, Firefox encodes them as UTF-8 code sequence.

Reproducible: Always

Steps to Reproduce:
1. Click on the given link.
2. There are many punycode links in the page - pay attention how well they work.
3. Save the HTML page.
4. Open the saved page (you will have to drag and drop, since Firefox cannot open Unicode named files by double clicking).
5. Try clicking the same links you were successfully using in Step 2.
Actual Results:  
An error message appears: "Server not found. The browser could not open the following site: www.%93%fa%93%ec%89w.jp". This is obviously not the address you were trying to open.

Expected Results:  
The link should have opened.
(Reporter)

Updated

10 years ago
Summary: Weblinks appear as UTF-8 codes instead of punycode in saved pages → Weblinks appear as unidentified code sequences instead of punycode in saved pages

Comment 1

10 years ago
This bug is related to / depends on bug 309671
This bug was originally reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.6 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Whiteboard: [CLOSEME 2010-07-30]
Version: unspecified → 2.0 Branch
No reply, INCOMPLETE. Please retest with Firefox 3.6.8 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Comment 4

8 years ago
I can reproduce this on 3.6.8 & 4.0b3.
(Reporter)

Comment 5

8 years ago
Just tried with 3.6.8. The bug still exists.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Updated

8 years ago
Whiteboard: [CLOSEME 2010-07-30]
Version: 2.0 Branch → 3.6 Branch
Reporter, Firefox 4.0.1 has been released, and it features significant improvements over previous releases. Can you please update to Firefox 4.0.1 or later, and retest your bug? Please also create a fresh profile (
http://support.mozilla.com/kb/Managing+profiles), update your plugins (Flash, Java, Quicktime, Reader, etc) and update your graphics driver and Operating system to the latest versions available. 

If you still continue to see this issue, please comment. If you do not, please close this bug as RESOLVED > WORKSFORME

filter: prefirefox4uncobugs
(Reporter)

Comment 7

7 years ago
Yes, the issue persists. "Copy link" function doesn't work properly either, although the correct link appears at the bottom of the browser window.
(Reporter)

Comment 8

7 years ago
I've just made the same experiment with Internet Explorer 8. The links in the document saved using IE do not appear as %-escaped characters. They are correctly handled by Firefox as well, and Internet Explorer 8 does not support %-escaped hostnames.
(Reporter)

Updated

7 years ago
Summary: Weblinks appear as unidentified code sequences instead of punycode in saved pages → Weblinks appear as %-escaped code sequences instead of punycode in saved pages
You need to log in before you can comment on or make changes to this bug.