Note: There are a few cases of duplicates in user autocompletion which are being worked on.

UI defaults with download_on_biff ON, biff OFF. UI work needed.

VERIFIED DUPLICATE of bug 63992

Status

SeaMonkey
MailNews: Message Display
P2
normal
VERIFIED DUPLICATE of bug 63992
17 years ago
13 years ago

People

(Reporter: laurel, Assigned: racham)

Tracking

({polish})

Trunk
mozilla0.9
polish

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

(Reporter)

Description

17 years ago
Using 2000-06-08 m17 commercial build

UI issue needs to be resolved concerning the pref in Account Settings Server
(POP only?) panel for download_on_biff (automatically download new messages).
This pref is directly related to mail notification (biff).

A new 6.0 profile/account server panel has the main biff pref default state as
disabled, but the download_on_biff pref enabled. This should not be.

The download_on_biff option should be tied to the biff pref.  UI handling in 4.x
varied among the different platforms.

1.  Create a new POP profile or new POP account.
2.  From mail window, Edit|Account Settings.  Select the account/Server panel
for the new POP account.
3.  Notice the default state for "Check for new messages every N minutes" is
disabled.  Notice the default state for "Automatically download any new
messages" is enabled.

Win32 4.x solution was to dim/grey the download new messages option regardless
of its enabled state if the main biff pref was disabled.
(Reporter)

Updated

17 years ago
QA Contact: lchiang → fenella
(Reporter)

Comment 1

17 years ago
cc jglick for any ui/spec relevant input

Comment 2

17 years ago
"Automatically download any new messages" is a sub widget of "Check for new 
messages every X minutes" and hence should only be enabled if its parent 
widget is enabled/check.  Otherwise, it should be disabled/grey. 

I'll made a note in the spec. 

Comment 3

17 years ago
moving to M18 as polish.
Target Milestone: --- → M18

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 4

17 years ago
Added "nsbeta3" and "correctness" keywords.
Keywords: nsbeta3, polish

Comment 5

17 years ago
nsbeta3- per mail triage review. Assuming that biff is off regardless of what 
download on biff setting is.
Whiteboard: [nsbeta3-]
Target Milestone: M18 → Future
(Reporter)

Comment 6

17 years ago
To answer Lisa's assumption, yes, the last time I checked (awhile ago), biff was
indeed enabled even though the sub-option showed as enabled in ui.  Correct biff
behavior, bad visual display in prefs.

Updated

17 years ago
Keywords: mail3

Comment 7

17 years ago
marking nsbeta1+
Keywords: nsbeta1
Priority: P3 → P2
Whiteboard: [nsbeta3-] → [nsbeta3-][nsbeta1+]

Comment 8

17 years ago
moving to mozilla0.8 milestone.
Target Milestone: Future → mozilla0.8

Comment 9

17 years ago
reassigning to racham.
Assignee: gayatrib → racham
Status: ASSIGNED → NEW

Comment 10

17 years ago
Hakan, did you file a dup of this earlier?

Comment 11

17 years ago
I'm not sure. But the bug *is* however in some way related to my fix in bug
63992. Please check it out and reopen if needed.

Comment 12

17 years ago
moving to mozilla0.9
Target Milestone: mozilla0.8 → mozilla0.9

Comment 13

17 years ago
Assign it to Sheelar
QA Contact: fenella → sheelar

Comment 14

17 years ago
this looks like a dup since the bug is fixed now.  

*** This bug has been marked as a duplicate of 63992 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Keywords: nsbeta3
Resolution: --- → DUPLICATE
Whiteboard: [nsbeta3-][nsbeta1+] → [nsbeta1+]

Comment 15

17 years ago
verifying as dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.