iframe height percent not drawn at proper percent

VERIFIED DUPLICATE of bug 25453

Status

()

Core
Layout: HTML Frames
P3
major
VERIFIED DUPLICATE of bug 25453
19 years ago
18 years ago

People

(Reporter: glynn, Assigned: Eric Pollmann)

Tracking

({testcase})

Trunk
All
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] iframe height percent ignored, URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
March 23 optimized apprunner and viewer
Mac 8.5/G3, Linux 5.2,  Win98

See related bugs - 3624 and 3790 - I verified 3624 for the crasher and this bug
is to continue tracking iframe percent height issue sans any CSS involvement.

1.  Launch Seamonkey and load test case page:
http://slip/projects/marvin/html/frametest/iframe_height_percent.html
2.  Look at height of iframe in relation to viewable page area.  Resize window
down as far as possible and observe iframe heights.

•  The 25% setting for both iframes is not respected.  They occupy 90% of the
page's height.  In viewer when I resize downwards page grows and there is no
change in height of iframes whatsoever. This is due to temp workaround from Bug
3790 where iframe was hardcoded for CSS and auto at 350 or 200 pixels.

Iframe should in auto mode should conform itself to relative height of page and
not the fixed workaround values or preset hard code arbitrary number; authors may
want small iframes.

Updated

19 years ago
QA Contact: 4082 → 4110

Comment 1

19 years ago
Chrisd, assigning Greg's open bugs to you.

Updated

19 years ago
QA Contact: 4110 → 3849

Updated

19 years ago
Target Milestone: M7

Comment 2

19 years ago
Moving to M7.

Comment 3

19 years ago
Moving to M9.

Updated

19 years ago
Assignee: karnaze → pollmann
Status: ASSIGNED → NEW

Comment 4

19 years ago
Reassigning frameset/iframe bugs to Eric.
beppe: could you attach the test case to this bug so that we can see it from
outside the Netscape intranet? Thanks.
(Assignee)

Comment 6

19 years ago
Created attachment 548 [details]
Test case
(Assignee)

Comment 7

19 years ago
This is still a fixed size.

Updated

19 years ago
Whiteboard: [TESTCASE] iframe height percent ignored

Comment 8

19 years ago
updated status line to "[TESTCASE] xxx" standard. again one position less on the
list :-) I think glynn@netscape.com's test case is good enought. Still not
working on both M7 and July 14 build.

Updated

19 years ago
Target Milestone: M10 → M11

Comment 9

19 years ago
m11

Updated

19 years ago
QA Contact: beppe → petersen
(Assignee)

Updated

19 years ago
Target Milestone: M11 → M12
(Assignee)

Comment 10

19 years ago
Moving non-critical bugs out.
(Assignee)

Comment 11

19 years ago
After careful consideration, I've decided that I probably won't get this bug in
for M12.  Currently I have nearly 50 bugs scheduled for M13, so there is a
possibility that this bug may need to be moved out farther still.
Target Milestone: M13 → M15
Moving to M15.
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase
(Assignee)

Comment 14

18 years ago
This is the same as bug 25453.  Technically that is a dup of this, but there are 
more complete test cases on that bug, so I'm duping this on that.

*** This bug has been marked as a duplicate of 25453 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 15

18 years ago
VERIFY duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.