If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

onchange not firing in text-input when selecting value from list and leaving the control

RESOLVED DUPLICATE of bug 388558

Status

()

Toolkit
Form Manager
RESOLVED DUPLICATE of bug 388558
10 years ago
9 years ago

People

(Reporter: fospald, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

Consider the following file:

<html>
	<head></head>
	<body>
		<form>
			<input name="x" id="x" type="text" value="Bug?" onchange="alert('onchange');">
			<input type="submit">
		</form>
	</body>
</html>

Follow the "Steps to Reproduce"...

Reproducible: Always

Steps to Reproduce:
1. Change the text to "Bug!" and leave the text box by clicking outside the text box. -> You get an alert message.
2. Delete the text "Bug!" and leave the text box. -> You get an alert 
3. Double click in the text box. -> a list appears.
4. Select the value "Bug!" from the list box.
5. Leave the text box. -> You get no NO alert!

Actual Results:  
onchange not firing

Expected Results:  
onchange firing

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 388558
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.