Feature request: Please allow to change the search engine by typing a short cut in the location bar.

RESOLVED WORKSFORME

Status

()

--
enhancement
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: r.spitzlinger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.8pre) Gecko/20070922 Camino/1.6a1pre (like Firefox/2.0.0.8pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.8pre) Gecko/20070922 Camino/1.6a1pre (like Firefox/2.0.0.8pre)

It would be great if the user could choose the search engine by typing a short cut into the location bar - followed by the search term.

That way the user does not have to choose the search engine each time (s)he carries out a new search. In stead the search engine is choosen at the same time as the search term itself. IMHO this would vastly accelerate the process. 

To enable such a feature, each search engine must have a (user defined) short cut. For example:

g = google.com
w = wikipedia
l = dict.leo.org


...and this is what it should produce:
* If I type: "g whatever" in the location bar, firefox should search the term "whatever" using google as a search engine.
* If I type: "l whatever", firefox should return the translation, using the translation service dict.leo.org

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
This feature already exists, see:
http://www.mozilla.org/products/firefox/smart-keywords.html

See also (more advanced) bookmarklets:
https://www.squarefree.com/bookmarklets/
(Reporter)

Comment 2

11 years ago
thanx for the hint. This is really a great!
Testing it, I found that my "bug report" may still have some value.

Smart keywords work for google and dict.leo.org but not for wikipedia. Any idea why? (I'm using 3.0b3 on a mac)

Comment 3

11 years ago
(In reply to comment #2)
> Smart keywords work for google and dict.leo.org but not for wikipedia.

Works for me, using current trunk build on Linux.
Go to http://en.wikipedia.org/wiki/Main_Page
In the search box to the left: use context menu to add keyword

If you open the Bookmarks window and look at the properties of that
bookmark you should find something like:
http://en.wikipedia.org/wiki/Special:Search?search=%s

(It's the %s that is replaced with what you type after the keyword --
this works for any bookmark by the way, if you add a keyword for it).
(Reporter)

Comment 4

11 years ago
There seems to be a conflict with the keywords. It works for some keywords, not for others.
Here is a list, with which ones it does/does not worke (all for the english version of wikipedia)

* wiki ...ok
* aa......ok
* a.......ok
* w.......I'm directed to the main page of wikipedia (no search performed)
* we......I'm directed to the main page of wikipedia (no search performed)

Comment 5

11 years ago
Still works for me.  Can you try again and make sure there is no item
highlighted in the location bar drop down menu when you press ENTER?
Does searching for w directly in the search box work?
If you open the Bookmarks window and look at Properties for this
bookmark - does it have same URL as I listed in comment 3?
(Reporter)

Comment 6

11 years ago
I deleted all wikipedia bookmark entries and added the search box again.
Now it seems to work for all keywords.

It really seems that firefox doesn't like multiple entries (with possibly the same keywords).


Comment 7

11 years ago
Ok, I'm resolving as WORKSFORME then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

11 years ago
Alright, sounds reasonable.
You need to log in before you can comment on or make changes to this bug.